Support » Plugin: Autoptimize » jquery still being optimized

  • Resolved johnmontfx

    (@johnmontfx)


    I’m getting some jquery errors, even though I’ve listed js/jquery/jquery.jsin the “Exclude scripts from Autoptimize” box. I can see the jquery code in the head of the aggregated file. I have Optimize JavaScript Code? checked and Aggregate JS-files? checked.

    Shouldn’t these settings leave jquery in the head? Or am I missing something?

    Thanks!

    • This topic was modified 10 months, 3 weeks ago by  johnmontfx.
Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m seeing this issue on another excluded script. It was being successfully excluded up until version 2.4.0.

    Rolling back to 2.3.4 resolves the issue.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @johnmontfx are you asyncing your JS or do you have cloudflare’s rocket loader active by any chance? if not; can you share your site’s URL so I can take a look?

    @joshf AO 2.4 minifies non-minified excludes JS, leading to the original filename to be replaced with wp-content/cache/autoptimize/js/autoptimize_single_xzy123.js but the file is actually still excluded. you can disable this extra optimization with a code snippet which is listed in the AO FAQ.

    hope this helps,
    frank

    Adding that filter did the trick.

    Although, it seems to make sense that if a script is excluded in the settings that it would automatically be excluded from all AO filters.

    Thanks for help!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Although, it seems to make sense that if a script is excluded in the settings that it would automatically be excluded from all AO filters.

    well, it is excluded from aggregation, but given that it is unminified minifying it seems like a good idea, exceptions (for which we have the filter) notwithstanding 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘jquery still being optimized’ is closed to new replies.