Support » Plugin: Five Star Restaurant Reviews » jQuery spectrum is not a function

  • Resolved Harm10

    (@harm10)


    In my web console when I use the admin side of the site:
    Uncaught TypeError: jQuery(…).spectrum is not a function
    <anonymous> myurl/wp-content/plugins/good-reviews-wp/assets/js/admin.js?ver=2.0.2:81

    What is wrong?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter Harm10

    (@harm10)

    Maybe related: I cannot click on tabs Visual and Text above the editor. Icons of edit selection are also not visible. This is not the case when I edit a regular Post.

    If I rollback to version 2.0.5 the Editor’s icons reappear but clicking Visual/Text tab is still not working. The jQuery error is also still there.

    • This reply was modified 2 months, 4 weeks ago by Harm10.
    Plugin Support jaysupport

    (@jaysupport)

    Hi Harm,

    First off, I just tested, to make sure, and all JavaScript/jQuery functionality is working correctly in the admin in the current version of our plugin.

    Does this happen when you’re trying to access the Styling area of the settings page? (I ask because that is where the spectrum colorpicker is used.) If so, you’ll need to contact us via email or our website (https://www.fivestarplugins.com/support-center), as discussion of the premium version is not allowed in these forums (https://wordpress.org/support/guidelines/#do-not-post-about-commercial-products).

    If you are not using the premium version, and this is happening elsewhere in the admin, then, normally, when you see a JS error that says something is not a function, that is usually caused by the jQuery library not being loaded correctly, which usually happens when it is being loaded more than once. And this is usually due to a plugin or the theme not correctly making use of the WordPress enqueue functionality. So, I would suggest that you double check in the page source code to see if this is indeed the case and, if so, find out which plugin (or the theme) is incorrectly loading jQuery and, then, when you have that resolved, and the jQuery library is being loaded correctly, and only once, then have another look at the admin area of our plugin to see if the jQuery/JS features are now working correctly.

    Thread Starter Harm10

    (@harm10)

    I use the free version and this error occurs only when I start the editor for a review.
    As this error is not occurring when I start the editor for a normal post and the error clearly points to a file within this plug-in I can only conclude this error is occurring because of some failing action in the plug-in.
    I tested on a test site which has single WordPress installed (latest version) and only a few active plug-ins to be sure there is no interference of other plug-ins.
    As I have other problems with the editor when editing a review (and not when editing a post) I suspect some is wrong in the loading of scripts within your plug-in.
    Do you have another explanation?

    Plugin Support jaysupport

    (@jaysupport)

    Oh, ok, so it’s specifically on the review edit/create screen. That was not clear from your original post, in which it was just mentioned that it was on the admin side of your site. Hence my questions to clarify. In that case, I think what is happening is just that our admin JS file that is intended to control the colorpickers is being loaded even on the post create/edit screen, but the spectrum JS file is not, which is resulting in our call to it not being defined. We can take a look to update the condition on that enqueue in the next update.

    That being said, it should have no effect on the post edit screen. I’m not sure what you’re talking about for visual or text. Unless you mean you’re still using the old classic editor?

    • This reply was modified 2 months, 3 weeks ago by jaysupport.
    • This reply was modified 2 months, 3 weeks ago by jaysupport.
    • This reply was modified 2 months, 3 weeks ago by jaysupport.
    Thread Starter Harm10

    (@harm10)

    Thanks for your answer and investigation of the problem for a next update.

    That being said: I am looking for a reason why both tabs in the Classic Editor (called Visual and Text) do not work when clicked. They do work when I edit a regular Post but not when when I edit a Review).
    The icons I am talking about are the array of icons normally displayed depending on Visual or Text that show you the options (like the insert of More). These are also not visible when editing a Review. I have no errors in the log and only that spectrum message in my webconsole.
    As described when rolling back to version 2.0.5 the icons reappear but clicking the editor tabs still does not work.
    Perhaps you can suggest an even older version to rollback to (I can as it is a test site) that should have a full working Classic editor for a Review?
    I might add that I am using this plug-in for a long time and previously I did not have problems with this.

    Plugin Support jaysupport

    (@jaysupport)

    My guess would be any version pre-2.0.0, which is the version in which the styling options were introduced. We’ll be updating the condition on that specific enqueue shortly in the next update, so, if that’s your issue, it will be rectified very soon.

    Plugin Support jaysupport

    (@jaysupport)

    Actually, the update to correct the enqueueing conditions (v2.1.3) has already just been released.

    • This reply was modified 2 months, 3 weeks ago by jaysupport.
    Thread Starter Harm10

    (@harm10)

    I have installed 2.1.3 and can report that the spectrum error message has disappeared!
    And………… the editor tabs are working again as are the icon displays!
    So I have to conclude that all those errors were related to the jQuery error?

    I have another message in my webconsole now concerning a Warning: Failed prop type: etc etc.
    But that message is also there when I edit regular Posts. So that will not be related I assume.

    So I guess this report can be closed?

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.