Support » Plugin: Net Neutrality » jQuery not defined

  • Resolved Caspar Hübinger

    (@glueckpress)


    If you use this plugin alongside a performance optimisation or caching plugin, and you have JavaScript concatenation enabled, you might run into a jQuery error. It would show up in the browser console on the front-end like this:

    ReferenceError: jQuery is not defined

    This might happen due to missing dependencies and can usually be fixed by changing this line:

    wp_register_script( 'net-neutrality-js', plugins_url( 'net-neutrality.js', __FILE__ ), array(), '20140904' );

    into this:

    wp_register_script( 'net-neutrality-js', plugins_url( 'net-neutrality.js', __FILE__ ), array( 'jquery' ), '20140904' );

    (Note the declared dependency: array( 'jquery' ))

Viewing 1 replies (of 1 total)
  • Plugin Author Eric Binnion

    (@ebinnion)

    Thanks you for reporting the issue. I have released 1.0.1 which properly registers the dependency.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.