Support » Theme: Neve » jQuery Migrate Helper — Warnings encountered

  • Resolved dicksijtsma

    (@dicksijtsma)


    Hi,

    using WP Bakery in Neve Theme worked fine. But after updating some plugins, the front-end got messed up. WP Bakery told me that it had to do with jQuery. Installing the jQuery Migrate Helper plugin pointed me to the Neve THeme.

    Despite the fact i’m working with the latest version of Neve, there is an error with jQuery that might cause the misbehaviour of the front-end.
    This is the error:

    https://www.kohnstammschool.nl/wp-content/themes/neve/assets/js/build/all/metabox.js: jQuery.fn.load() is deprecated

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter dicksijtsma

    (@dicksijtsma)

    In the file metabox.js, found in the neve/assets/js/build/all folder, a depricated jQuery function is found. The function is deprecated in 2012!

    You should replace the part .load(function(){jQuery.neveMetabox.init()})}(); with .on(“load”, function(){jQuery.neveMetabox.init()})}();

    Please come with an update of the theme for this and check the rest of the code too. WordPress 5.5 changes a lot on the jQuery side. You better prepare your Theme for that, even if the Theme is free. Thanks.

    Hi @dicksijtsma,

    Thank you for reporting this – we have forward it to our developers for the review and will most likely release a fix with one of the following releases of the Neve theme.

    Let us know if you have any other questions or suggestions.

    I am having the same issue with wp-content/themes/neve/assets/js/build/all/metabox.js: jQuery.fn.load() is deprecated, although I am not seeing immediate frontend issues so far, I’m having completely different symptoms, where any new product imports in woocommerce, the spaces within the download URLs are being encoded with %20 thus leading to 404 pages when someone tries to download a purchased product.

    Hi @aymenyaseen,

    This looks like a completely different issue so please create a new thread if you think it’s related to the Neve theme. I would recommend you to try checking the Settings->Permalinks section in WordPress to change the behavior of how links are created in your WordPress instance.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘jQuery Migrate Helper — Warnings encountered’ is closed to new replies.