Support » Plugin: Advanced Shipment Tracking for WooCommerce » jQuery.live() will cause an error in WP 5.5

  • Resolved Paul Biron

    (@pbiron)


    In assets/js/shipping_row.js there is a call to jQuery.live(). That function was removed from jQuery in version 1.9.

    Versions of WP prior to 5.5 have loaded jquery-migrate.js which provides a polyfil for it, but version 5.5 will not do so. See Updating jQuery version shipped with WordPress.

    You should replace that call with jQuery.on() (see .live()). There are many other uses of jQuery.on() in your code so it seems like you know how to use it.

    You can test this by installing WP 5.5 Beta 3 and activating this plugin.

    • This topic was modified 10 months, 3 weeks ago by Paul Biron. Reason: fix typo
Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter Paul Biron

    (@pbiron)

    Another change you’ll need to make before WP 5.5 ships (pun intended 🙂 has to do with a registering REST Routes. 5.5 is scheduled for release on Aug 11.

    In 5.5, if you do’t pass a permission_callback when registering a route core will call _doing_it_wrong(). See the “Warn when omitting a permission_callback” section of REST API changes in WordPress 5.5.

    Thread Starter Paul Biron

    (@pbiron)

    Just wanted to say: I really like this plugin (and your Tracking Per Item Add-on for it)…it’s really going to solve some problems for a client of mine (will be sure to leave a review once we’ve used it for a little while)!

    Plugin Author zorem

    (@zorem)

    Hi @pbiron
    Thank you so much! I am passing your comments to the developers to check, I will let you know..

    Plugin Author zorem

    (@zorem)

    Hi @pbiron,

    We updated jQuery in shipping_row.js and released the latest version of the AST.

    Thanks,

    Thread Starter Paul Biron

    (@pbiron)

    Thanx for the quick turn around on that. I can confirm that 3.0.7 fixes the JS problem w/ WP 5.5.

    Can you open this topic back up until the REST API issue is fixed in a future release? Or should I start another topic for that issue?

    Plugin Author zorem

    (@zorem)

    We will add the change for the API in the next plugin release.
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘jQuery.live() will cause an error in WP 5.5’ is closed to new replies.