Support » Plugin: Quick Event Manager » jQuery legacy folder not used in updated site?

  • Resolved WebDeb

    (@sillymoney)


    When “Enable jQuery Migrate Helper” is activated it provides the following message:

    ../plugins/quick-event-manager/legacy/quick-event-media.js: jQuery.fn.size() is deprecated; use the .length property

    But everything seems to be working great; no errors were found in the error log with the bit of testing I did.

    Since the site is on WordPress 5.5 that the code in the “legacy” folder, am I correct that it would not be used & all is well? As in “Enable jQuery Migrate Helper” is not needed?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author fullworks

    (@fullworks)

    Thank you for your question.

    Firstly the legacy folder is used, but holds code from the original developer, but allows me to re-engineer in stages.

    .size() is indeed deprecated, but still works and jQuery migrate is not needed for this in WP 5.5

    Just fyi, the next release in development already uses .length rather than .size()

    Thread Starter WebDeb

    (@sillymoney)

    Thank you! Now I can sleep at night.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘jQuery legacy folder not used in updated site?’ is closed to new replies.