Support » Fixing WordPress » jQuery issue with order in head

  • Resolved Daimoch

    (@daimoch)


    Hello,

    wordpress auto puts the lates jquery version into the <head> tag:
    <script type=’text/javascript’ src=’http:/mysite.de/wp-includes/js/jquery/jquery.js?ver=1.7.1′></script>.

    That version is needed for some plugins and works!

    Now i put my very own javascript into the <head> right before the end of the </head> tag. That script doesn’t work now. But when i put manually a link to a ealier version of jquery (<script src=”http://mysite.de/wp-content/themes/twentyeleven/js/jquery-1.4.1.js”></script>) ABOVE my script, it works, but the other plugins don’t because they need the latest jQuery version.

    But my javascript works definitly in latest jQuery version! I’ve tested it.

    Where is the problem? jQuery is loaded else my plugins wouldn’t work but it has no effect to my javascript in the <head> not until i put a link to jQuery additionally above my script.

    Hope you can help

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘jQuery issue with order in head’ is closed to new replies.