Support » Fixing WordPress » jQuery is not defined – Can't Upload Media Files

  • jQuery is not defined – media-upload.php iframe
    Ok I am finally caving and posting a support thread. I’ve been banging my head against the wall for hours now thank god for coffee. I consider myself rather competent with javascript and I’ve tried countless fresh installs but nothing seems to be working. I’ve gone through all js-related issues on but I still have had no luck.

    jQuery seems to be working just fine on my dashboard. However, when I try and upload a media file I get the thickbox popup without any issue but it loads with “jQuery is not defined” errors. As a result, the drag-and-drop box never appears and the “select files” button and “browser uploader” link do not work at all. I can’t insert a media file or set a featured image which is a serious problem.

    load-scripts.php:2 Uncaught SyntaxError: Unexpected string
    media-upload.php:87 Uncaught ReferenceError: jQuery is not defined
    load-scripts.php:1 Uncaught ReferenceError: jQuery is not defined
    load-scripts.php:2 Uncaught SyntaxError: Unexpected string
    media-upload.php:87 Uncaught ReferenceError: jQuery is not defined
    load-scripts.php:1 Uncaught ReferenceError: jQuery is not defined

    jQuery seems to be uploaded fine. I’m currently fiddling around with this domain and I see jQuery loads well – . Am I experiencing an issue with permissions? I haven’t altered any since fresh factory install but this issue has arisen on my other sites that used to be working fine.

    Please help, I really need to update my Blogs – I run around 10 WP blogs that earn me money I rely on. All of my top earning blogs have been giving me this issue after updating to 3.3.1. I am the kind of person who finds my own answers through google or existing threads but I’ve tried everything. I am willing to pay someone to provide a solution – perhaps manually fix it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Oh wow… Why is this not in the 3.3 Troubleshooting FAQ?! I was trying to edit my website in Chrome but everything seems to be working fine in Firefox and IE!

    Lesson learned: WordPress dashboard and Google Chrome DO NOT MIX. As I said above I spent hours trying to figure out how to fix it, dismantling a website over and over and reading hundreds of responses and threads. Please, for everyone’s sake – add a note on the 3.3 troubleshooting page about the incompatibility with Chrome here:

    I run quite a few WordPress 3.3.1 sites and have absolutely no problems using the Admin within Chrome. So whatever this is, it is specific to your site.

    I am going to try and update Chrome I could imagine this may be the problem. I’ll report back when I’ve done so!

    What I’ve found after a bunch of browser compatibility testing. Tested with 3 different versions of WordPress. I’ve even tested different themes to make sure that wasn’t causing the issue.

    • Chrome version 17.0.963.56 m (most recent). I get the same issue (jQuery is not defined).
    • I’ve tested them with FireFox version 10.0.1 and it worked fine.
    • Tested with IE version 8.0.7600.16385 64-bit and it also worked fine.

    Maybe you’re using an old version of Chrome that is compatible with the WordPress Dashboard because I am having absolutely no luck with it. This definitely seems to be an issue with Chrome.

    I really hope this helps because it took me a while to test all these features with different browsers, themes and WP versions. Hopefully this will point the developers in the right direction for a fix. I love WordPress and I hope I’ve contributed something useful!

    Maybe you’re using an old version of Chrome

    Nope. Same version. Just tested it again and no issues uploading an image file.

    I am seeing this exact same issue. It’s happening with WordPress 3.3.1 and Chrome, but not in any other browsers. I am using the current latest version of Google Chrome – 17.0.963.79.

    Here’s the really weird thing though – I have WordPress on many sites, and this is only happening to one of them. It’s a brand new install, no custom theme, no plugins yet.

    There must be some kind of relation between the host and the issue, although I can’t imagine what. The host for the site with the issue is Network Solutions, while my other WordPress sites not having the issue with Chrome are on GoDaddy or other hosts. Very, very weird.

    o i have a bit different problem i think but maybe you guys can help me:

    i migrated blog, exported content, moved themes and plugins. can see content on the dashboard ( with images ) but not on site? also, media library is empty ( i moved all uploads to a new server ) and i can’t even open Media when creating a new post.

    i read about changing permissions but it doesnt work. HELP>

    @cr & @fotogenico: It is impolite to interrupt another poster’s thread with a question of your own. Please post your own topics.

    Is this problem already sorted out one way or the other? I’m having exactly the same issues at the moment.

    I even tried to upload the image with FTP to the wp-uploads folder but WordPress doesn’t seem to find it either.

    By the way 0_00_0, did you try to delete a plugin through the plugin list? I think it’s having the same problem than uploading media files.

    Just found have of the problem, being not able to delete any more plugins (thinking that still problem is still related to jQuery and uploading media files). The SEO Facebook Comments plugin was preventing me from deleting plugins through the plugin list in wordpress. It didn’t fix the media uploading problem though. Keep looking!

    Finally found the problem! Deactivate the Exec-PHP plugin. This plugin executes <?php ?> code in your posts, pages and text widgets, but is also messing up the jQuery for uploading media files. I hope it works out for you as well!

    I dont know if it would help but if your website is hosted as a virtual site, then you should contact the tech support of your hosting company and ask them to change something the mod_security settings on your site
    so that you can upload from the media library. most of the time, you as subscribers of virtual sites dont have access to it and only the tech support knows what to do.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘jQuery is not defined – Can't Upload Media Files’ is closed to new replies.