Support » Plugin: Logo Carousel » jquery is not defined

  • Resolved englishwebsite

    (@englishwebsite)


    Hello,

    The widget was working great, and then it stopped working correctly (simply shows all the logos vertically with no script running).

    So now when I load my page it tells me that the jquery is not defined and to reload page to get the source for the bxslider…

    The plugin simply shows all the logos in a vertical line with no effects, no styling, and horizontal styling or autoplay…

    Any help on to figure the problem behind this would be great. I’m not sure where to look to solve the problem?

    I did a lot of modifications to my website, and so it’s impossible for me to figure out which modification caused the problem… I’m not sure I can even remember all the modifications to rollback! I think maybe there was a conflict when I uninstalled a plugin (q2w3 fixed widget plugin). Before uninstalling, kiwi logo worked and after uninstalling the fixed widget plugin, kiwi stopped working. But I tried re-installing the plugin and no luck fixing kiwi! So I’m at a loss..

    Thanks for your help!

    https://wordpress.org/plugins/kiwi-logo-carousel/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Yourstyledesign

    (@ysdbjorn)

    Make sure your WordPress theme uses jQuery.
    And make sure jQuery is loaded before the plugin javascript.

    Thanks for your answer. I’m not very knowledgeable so maybe you can help out with more details?
    I’m pretty sure my wordpress theme was using jquery fine. I have other plugins that work fine…
    I’m not sure how to check if the jquery is loaded before the plugin.

    maybe I can send you the link to my website? would that help you see the problem?

    Thanks!

    I just added the following code to my index.php page and it solved the problem. Any explanation on why this solved the problem would be awesome!

    Thanks

    <?php function load_scripts() {
    		wp_deregister_script( 'bxslider' );
    		wp_register_script( 'bxslider', plugins_url( '/third-party/jquery.bxslider/jquery.bxslider.js', __FILE__), array(), false, false);
    		wp_enqueue_script( 'bxslider' );
    
    		wp_deregister_style( 'bxslider-css' );
    		wp_register_style( 'bxslider-css', plugins_url( '/third-party/jquery.bxslider/jquery.bxslider.css', __FILE__) , array() , false, false);
    		wp_enqueue_style( 'bxslider-css' );
    
    		wp_register_style( 'kiwi-logo-carousel-styles', plugins_url( 'custom-styles.css', __FILE__) , array() , false, false);
    		wp_enqueue_style( 'kiwi-logo-carousel-styles' );
    	} ?>
    Plugin Author Yourstyledesign

    (@ysdbjorn)

    The scripts off Kiwi Logo Carousel are loaded in the footer. When jQuery is also loaded in the footer by your theme. It is possible that the Plugin’s javascript is loaded before the theme’s jQuery.

    This results in a not working plugin. Moving the code that loads the scripts can solve this problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘jquery is not defined’ is closed to new replies.