WordPress.org

Forums

jQuery is disabled and this widget needs it (11 posts)

  1. metacomedy
    Member
    Posted 5 years ago #

    Site: http://metacomedy.com/

    Theme: mystique

    Error: "jQuery is disabled and this widget needs it"

    Tried: (1) in headers.php, added wp_enqueue_script('jquery'); before wp_head(); and (2) adding jquery.js to the mystique theme folder.

    What else might one try?

    Best,
    metacomedy

  2. What widgets are those? Because jquery is not disabled on your site, and is in fact loading just fine.

  3. metacomedy
    Member
    Posted 5 years ago #

    Ah, perhaps I simply haven't yet configured those widgets, and they came as defaults with the theme?

  4. mike5906
    Member
    Posted 5 years ago #

    I am having the same issue.

    I use Mystique on another website. However, I just installed WordPress MU and installed Mystique and I get the same error on the widgets.

  5. Danstinebaugh
    Member
    Posted 5 years ago #

    I'm also having this error on my site as I wanted to try out this awesome looking theme!

    site: http://stinebaugh.info

    I've also added the jquery-1.3.2.js file to my theme's directory , tried renaming it to jsquery.js like posted above, but still no luck, I'm not sure if I need to add anything to the header.php file like the first post mentioned and if so the exact code would be appreciated, as it shouldnt be that hard to do.

    Thanks in advance!

  6. himanshu21
    Member
    Posted 5 years ago #

    Try going to "Mystique settings" -> General and click on the "Reset to Defaults" button. It worked for me.

  7. digitalnature
    Member
    Posted 5 years ago #

    that message should only display when jQuery is disabled form the theme settings/advanced page...

  8. Stian Andreassen
    Member
    Posted 5 years ago #

    It's probably the Dashboard which needs jQuery. Try adding this to your theme's functions.php, as that loads both in the frontend and backend:

    function mytheme_init() {
    	wp_enqueue_script('jquery');
    	wp_enqueue_script('jquery-ui-core');
    }
    add_action('init', 'mytheme_init');

    This will enqueue jQuery for both front and back ...

  9. digitalnature
    Member
    Posted 5 years ago #

    oops my mistake. the default settings are not installed because of a bug, so many options are disabled, including jquery.

    those who are using mystique 1.61, press the reset settings button to fix this.

  10. Danstinebaugh
    Member
    Posted 5 years ago #

    Thanks for the quick responses! That worked a treat, and I love how powerful your theme is! So Customizable! Great Work!

  11. Danstinebaugh
    Member
    Posted 5 years ago #

    Such great work I just made a small donation! Really an awesome theme!

Topic Closed

This topic has been closed to new replies.

About this Topic