Support » Plugin: WordPress PDF Light Viewer Plugin » jQuery.fn.size() is deprecated in WP 5.5

  • Resolved skoen

    (@skoen)


    Is this plugin still maintained and supported?
    I am getting several jquery warnings in WP 5.5.

    plugins/pdf-light-viewer/resources/assets/js/admin.js: jQuery.fn.size() is deprecated; use the .length property

Viewing 13 replies - 1 through 13 (of 13 total)
  • JoskeVermeulen

    (@joskevermeulen)

    I have the same problem. But all is working fine.

    jQuery Migrate Helper β€” Warnings encountered
    This page generated the following warnings:

    /wp-content/plugins/pdf-light-viewer/resources/assets/js/admin.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer/resources/assets/js/admin.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer/resources/assets/js/admin.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    Please make sure you are using the latest version of all of your plugins, and your theme. If you are, you may want to ask the developers of the code mentioned in the warnings for an update.

    Same trouble here ? Any update ?

    Looks like the developers have lost interest in supporting this plugin. The fix would take no effort.

    Last updated: (over a year ago)
    1.4.7 – 2019-07-03

    And this message:
    This plugin hasn’t been tested with the latest 3 major releases of WordPress.

    Issues is outdated jQuery code:
    jQuery.fn.size() is deprecated; use the .length property

    If you have FTP access, you can download, fix, and upload these three files:
    /wp-content/plugins/pdf-light-viewer/resources/assets/js/magazine.js
    /wp-content/plugins/pdf-light-viewer/resources/assets/js/admin.js
    /wp-content/plugins/pdf-light-viewer/resources/assets/js/quick-edit.js

    replace “.size()” with “.length”

    –RayJ

    Thanks Ray, that helped. An easy job. πŸ˜‰

    Plugin Author antongorodezkiy

    (@antongorodezkiy)

    Thank you, @raywjohnson

    @skoen @joskevermeulen @johnccg I also added a fix to 1.4.8

    Thread Starter skoen

    (@skoen)

    Perfect. I’m marking this as solved.

    You are most welcome! @antongorodezkiy

    Hmmm….

    An update for the plugin and it is back where it was? I have to do the replace β€œ.size()” with β€œ.length” of Ray (thanks Ray!) What was the purpose of the update? πŸ˜‰

    Plugin Author antongorodezkiy

    (@antongorodezkiy)

    Indeed strange, this is what I get now:

    jQuery Migrate Helper β€” Warnings encountered
    This page generated the following warnings:

    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    /wp-content/plugins/pdf-light-viewer-pro/assets/js/magazine.js: jQuery.fn.size() is deprecated; use the .length property
    Please make sure you are using the latest version of all of your plugins, and your theme. If you are, you may want to ask the developers of the code mentioned in the warnings for an update.

    Hello again,

    I thought I download the PDF Light Viewer PRO Addon and the PDF Light Viewer Serverless Addon from CodeCanyon and reinstall it. But the PDF Light Viewer PRO Addon can’t be installed. It always says: The link you followed has expired. Please try again.
    The PDF Light Viewer Serverless Addon installed perfectly.

    Plugin Author antongorodezkiy

    (@antongorodezkiy)

    @joskevermeulen I see – that’s from Pro Addon. Please email us the link you’re trying to use or screenshot to the support@teamlead.pw.

    Thanks, I did send you an email.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘jQuery.fn.size() is deprecated in WP 5.5’ is closed to new replies.