Support » Fixing WordPress » JQuery Error with Buttons/Links

  • Resolved kylevcs

    (@kylevcs)


    Hi,

    Getting this error on any page, when we click a button or link:

    Uncaught TypeError: Cannot read property ‘defaultView’ of null
    at Ie (jquery.min.js?ver=3.5.1:2)
    at Be (jquery.min.js?ver=3.5.1:2)
    at Function.css (jquery.min.js?ver=3.5.1:2)
    at jquery.min.js?ver=3.5.1:2
    at $ (jquery.min.js?ver=3.5.1:2)
    at S.fn.init.css (jquery.min.js?ver=3.5.1:2)
    at startButtonLoader (frontend-min.js?ver=1602700983:formatted:662)
    at addToCart (frontend-min.js?ver=1602700983:formatted:731)
    at HTMLDocument.<anonymous> (frontend-min.js?ver=1602700983:formatted:297)
    at HTMLDocument.dispatch (jquery.min.js?ver=3.5.1:2)

    We have a multi site system, and this is the ONLY site having this problem.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • The “55+/Military/Student” and “Nibble of Tokens (6 Pack)” add to cart buttons appear to be working correctly on your page. I compared the broken buttons to those ones, and it appears that the broken ones are missing the “ajax_add_to_cart” class, and their URLs are page URLs instead of the ?add-to-card=POSTID url query. I’m not personally sure what may become causing that issue, but it might be worth asking in the WooCommerce forums:

    https://wordpress.org/support/plugin/woocommerce/

    @kjellr Thank you for that. The problem I am referencing is (more specifically) when you click on the “tickets” button at the top. The Jquery error shows in the console.

    This is not a woocommerce problem, but a wordpress issue. I also cannot click on any of the “wp admin buttons” in the top bar when signed in.

    • This reply was modified 1 month, 1 week ago by kylevcs.

    Ah, I see. Have you tried disabling the XT WooCommerce Floating Cart plugin for this site? When I click those links, I’m seeing the exact same error as the “Add to Cart” buttons. Clicking any of those links also involves some xt_woofc_ classes being added and removed in quick succession to the html wrapper. The console error appears to reference by a line in that plugin’s frontend-min.js file.

    In general, I’d recommend deactivating and individually re-activating any installed plugins to see if any of them are the culprit.

    @kjellr That was the issue! Thank you!

    Excellent! If you do need to continue using that plugin, you might try posting a question in their forum here:

    https://wordpress.org/support/plugin/woo-floating-cart-lite/

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.