Support » How-To and Troubleshooting » [Resolved] jQuery error on 3.6 upgrade jquery-1.10.2.min.map 404

[Resolved] jQuery error on 3.6 upgrade jquery-1.10.2.min.map 404

Viewing 15 replies - 16 through 30 (of 36 total)
  • I’m getting this as well..

    GET https://s1.wp.com/_static/jquery-1.10.2.min.map 400 (Bad Request)

    I think this is a Jetpack error?

    I cannot find any other posts or resolutions on it though??

    On a site I administer they were seeing this. I traced it to the Ozh’ Admin Drop Down Menu plugin. I upgraded it and all was well again. If you’re not using that plugin then try deactivating plugins in turn until you find the culprit. If you can update it do, otherwise leave a message on the plugin’s forum asking them to look into the issue.

    I get this error on all pages, I disabled all plugins, I activated the 2013 theme, and I check front end and back end, the same 404 message shows up. I actually think its connected to the WP-Admin bar, simply because the script that creates it is very close to the admin bar, and I only see the error when logged in.

    Anyone know of a solution?

    Same issue here – 404 in the admin

    I sorted this by de-registering jQuery in functions.php:
    <?php wp_deregister_script( 'jquery' ); ?>
    – really didn’t like having a wp-includes/ directory in my source code.

    Obviously you need to register a new jquery after doing this if your theme relies upon it, but that’s a good thing. I like to control how, where, and which version gets loaded:
    – not forgetting to enqueue it afterwards, of course.

    This works fine but seems to affect both the front and back-end. Not a problem, but annoying. I’m sure previous versions of WP didn’t do this but I could be wrong.

    simonseddon, you can wrap the de-register/register inside a condition using !is_admin()



    It’s not a prob just for source debug. It can be closed by uncheck the “Enable source maps” setting in Developer Tools.



    kudos to kim vin! I unchecked “Enable source maps” in Chrome Developer Tools, and the jquery-1.10.2.min.map 404 error went away.

    So this isn’t actually a problem with WordPress but rather a bug in Chrome Dev tools? That’s where I’ve seen the error, haven’t bothered checking in Firebug.

    I made a long post about how my “enable source maps” was checked and I was still getting an error…and then I reread haha. UNchecked.

    However, doing this means you cannot edit JavaScript on that page, correct?

    Are there any other implications to unchecking this box on Chrome?

    This is a wordpress 3.6 issue. This will be resolved in 3.6.1


    in the meantime remove the:

    //@ sourceMappingURL=jquery-1.10.2.min.map
    /wp-includes/js/jquery/jquery.js line 2

    as mentioned above and update to 3.6.1 when its released.

    @jsonb123, @devin Walker
    It’s a tool for keep your client-side code readable and more importantly debuggable even after you’ve combined and minified it, for more detail: Introduction to JavaScript Source Maps

    I tried removing line 2 and the problem still exists. I’m also getting the same problem with js/lib/backbone-min.map.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[Resolved] jQuery error on 3.6 upgrade jquery-1.10.2.min.map 404’ is closed to new replies.