Support » Plugin: Helpful » jQuery breaks on version 4.2.25

  • Resolved josephconlon

    (@josephconlon)


    My jquery dropdown menu code doesn’t work when I upgrade to the new version.

    It should hide the menu but when upgraded to the newest version, it doesn’t. The previous version doesn’t affect it.

    $(document).click(function(e) {
    var target = e.target;
    if (!$(target).is(‘li.dropdown a’) && !$(target).parents().is(‘li.dropdown a’)) {
    $(‘.sub-one’).hide();
    }
    });

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Pixelbart

    (@pixelbart)

    @josephconlon

    Your Javascript is also very general. You should already tell in the Click-Event what the event applies to:

    $(document).on('click', 'li.dropdown a', function(e) {

    Plugin Author Pixelbart

    (@pixelbart)

    But you’re right, there’s something wrong with the code. I’ll fix it right away.

    Plugin Author Pixelbart

    (@pixelbart)

    Should be fixed with the latest version. If not, just report it. Then I’ll take another look.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.