Support » Plugin: Jigoshop » jQuery blockUI version problem

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jigoshop Support – Paul

    (@paulpreston)

    Hi jumpinsteph,

    You can always update it manually.

    We have got significant amount of websites which we update regularly and we very rarely experience any problems. you may want to review hosting platform before jumping into conclusions.

    based on our experience hosting is often the reason behind all the issues with updates.

    HTH

    I had the same issue with a site running jigoshop.
    I found this link helpful:
    http://wordpress.org/support/topic/troubleshooting-wordpress-36-master-list?replies=5

    Specifically, replacing blockUI with the newer version from github.

    Hi,

    I’m having the same problem and have come to the conclusion that it is the Jigoshop plugin causing the problem.

    I’ve read the link above, as well as this one – http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution – but I don’t know how to fix it.

    Can someone please explain in simple terms, EXACTLY what I need to do to fix it… What piece of code do I need to get rid of, what should I replace it with, and in which file?

    I don’t understand how I would go about “replacing blockUI with the newer version from github” – what am I meant to do?

    Thanks to anyone who can help.

    Sami

    thedittmer

    (@thedittmer)

    Let me start by saying that I’m probably doing this wrong. So if someone reads this and knows a better way to do this, I’m all ears.

    I was having the same problem with jigoshop after upgrading WordPress. However, I found a solution. In the jigoshop plugin folder. Open assets -> js -> jigoshop_backend.js

    After you open the jigoshop_backend.js file find this bit of code at the top of the page and delete it:

    ;(function($){if(/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery)||/^1.1/.test($.fn.jquery)){alert('blockUI requires jQuery v1.2.3 or later! You are using v'+$.fn.jquery);return;}

    Save the file and BAZINGA, it works.

    jumpinsteph

    (@jumpinsteph)

    Hi,

    I’m still having this problem.

    I try to replace the code in three files in the jigoshop plugin (blockui.js, jigoshop_backend.js, jigoshop_frontend.js) by the code we find here >> http://malsup.github.io/jquery.blockUI.js
    as it is explained http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution

    but the problem is still here…

    I use a plugin jQuery Updater, so there is no error message on the frontend, but still in the backend… and I don’t want to use a plugin for that…

    can someone explain what to do exactly ? thank you so much.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘jQuery blockUI version problem’ is closed to new replies.