WordPress.org

Support

Support » Plugins and Hacks » jQuery blockUI error do to new jQuery v1.10.2 in wordpress 3.6

jQuery blockUI error do to new jQuery v1.10.2 in wordpress 3.6

Viewing 15 replies - 1 through 15 (of 26 total)
  • Ok so the infringing file is wpdeals_plugins.js found in the “wpdeals-assets > js” folder i tried replacing the entire file with a renamed jquery.blockUI.js but its to different. Would anyone know how to contact the auther and ask for a fix?

    I was told to use JQuery Updater but it doesn’t seem to fix it.

    http://wordpress.org/plugins/jquery-updater/

    +1

    I am interested on this too

    If you know what you are doing then you may:

    comment the if that checks the jQuery version using /*…*/
    The following needs to be commented in:

    wpdeals_plugins.js and wpdeals_admin.js

    if (/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery) || /^1.1/.test($.fn.jquery)) {
    	alert('blockUI requires jQuery v1.2.3 or later!  You are using v' + $.fn.jquery);
    	return;
    }

    Hi CandorZ,

    I had comment it in wpdeals_admin.js, I can’t find any code about the IF in wpdeals_plugin.js.

    However, I still receive the alert at WPDeals panel.

    Updated It’s work after few times refresh.

    By the way, I had set 10 vouchers code, but when I try buy 2 vouchers, email and account list only show 1 voucher code. Anyone know the solution?

    I have the WP Deals Plugin and cannot find wpdeals_plugin.js can someone share the file path for this file? Im having the same issue as everyone else.

    Ok I found it 🙂
    wp-content/plugins/wp-deals/wpdeals-assets/js/wpdeals_plugins.js

    Commenting out the If statements in those 2 files did not fix the problem?

    This is the wpdeals_admin.js

    ;(function($){ /*if(/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery)||/^1.1/.test($.fn.jquery)){alert(‘blockUI requires jQuery v1.2.3 or later! You are using v’+$.fn.jquery);return;} */

    How would I fix the jQuery issue? Once I commented out those if statements the back end works fine but I now get the popup on the front end.

    Sincerely,
    Michael

    Alrighty So now it works…..?
    😀 😀 😀 😀 😀
    Refresh issue???

    Is there a definitive answer to this problem yet?

    Mikhail_S

    @mikhail_s

    Write a step by step – how to solve this problem

    can one of the clever ones tell us if this problem is secific to the plugin ? if so maybe we should ask the creators for a fix. I have used the jquery update plugin and it doesnt seem to affect the fornt end its just annoying on the back end

    CandorZ

    @candorz

    It’s something to do with the REGEX

    if(/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery)||/^1.1/.test($.fn.jquery))

    which is checking the version of JQuery

    You are free to resolve it or comment out the

    if(/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery)||/^1.1/.test($.fn.jquery)){alert('blockUI requires jQuery v1.2.3 or later!  You are using v'+$.fn.jquery);return;

    in wpdeals_admin.js
    and

    if (/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery) || /^1.1/.test($.fn.jquery)) {
    	alert('blockUI requires jQuery v1.2.3 or later!  You are using v' + $.fn.jquery);
    	return;

    in wpdeals_plugins.js

    I have already informed the developer

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘jQuery blockUI error do to new jQuery v1.10.2 in wordpress 3.6’ is closed to new replies.