WordPress.org

Support

Support » Plugins and Hacks » [Resolved] JQuery animation doesnt work (bar mode)

[Resolved] JQuery animation doesnt work (bar mode)

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author SKTThemes

    @sonalsinha21

    Hey,

    I noticed the support thread now. Sorry didn’t get email for this one.

    We are checking it and letting you know in the next hour.

    Regards,
    Shri

    Plugin Author SKTThemes

    @sonalsinha21

    Hi,

    It is working for 3.7.1 and not for 3.8.

    Never thought it would not work.

    Give me time till tomorrow.

    Will solve it and post the updated plugin in wordpress.

    Plugin Author SKTThemes

    @sonalsinha21

    Hi,

    We updated the plugin recently. Can you download the latest version now and let me know if it works for you?

    Here is the link to our page in wordpress 3.8

    http://www.sktthemes.net/demo/towing/uncategorized/hello-world/

    I encountered the same problem with my bar chart (downloaded it about 2 hours ago).
    Figured out that the problem lays within the ‘appear’ plugin.
    I removed the if statements from the sbar function (sktskillbar.php, around line 64) and that made it work.

    case 'bar':
    			$wrapCode = '<div id="skillbar_straight" style="padding:10px 0;">'.do_shortcode($content).'<div style="clear:both;"></div></div>';
    			$wrapCode .= '<script>
    				function sbar(){
    					jQuery(".skillbar").each(function(){
    						jQuery(this).find(".skillbar-bar").animate({
    							width:jQuery(this).attr("data-percent")
    						},3000);
    					});
    				}
    				if ( jQuery("#skillbar_straight").next().is(":appeared") ){
    					sbar();
    				} else {
    					jQuery( window ).scroll(function() {
    						if ( jQuery("#skillbar_straight").next().is(":appeared") ){
    							sbar();
    						}
    					});
    				}
    				</script>';
    			break;

    Only problem now is that the animation starts on pageload.

    Any ideas on how to solve this?

    Thanks in advance

    Plugin Author SKTThemes

    @sonalsinha21

    Yes the problem is it is working on some and not working on others so just trying to find out which script is causing the problem.

    Working on it.

    Did not work with me on 3.8 ???

    Plugin Author SKTThemes

    @sonalsinha21

    Hi,

    Updated the plugin to version 1.1 not sure how to update versions as this is something new for us.

    Kindly download the new plugin from wordpress and this is solved.

    Let us know

    Hi, I downloaded your plug-in about a week ago and it worked well then, but now since I’ve updated my wordpress to 3.8, it’s stopped working.
    I wonder if this issue has been solved or not.

    just in case, you can see it here: http://sominheo.com/about/

    Thanks!

    Plugin Author SKTThemes

    @sonalsinha21

    Hi Sominhoe,

    Kindly remove the previous version and redownload the latest version 1.1 and it should be working on your wordpress version 3.8.

    Chrom Dev Console at sominheo.com/about/ reports jQuery not defined for a number of js files.

    I think adding array(‘jquery’) to the sbar_register_scripts function in sktskillbar.php file might do the trick.
    So it would look like this:

    function sbar_register_scripts() {
    	if ( !is_admin() ) {
    		wp_register_script('bar_script', plugins_url('skill_bar/bar/jquery.appear.js', __FILE__), array('jquery'));
    		wp_enqueue_script('bar_script');
    
    		wp_register_script('circle_script', plugins_url('skill_bar/circle/jquery.easy-pie-chart.js', __FILE__), array('jquery'));
    		wp_enqueue_script('circle_script');
    
    		wp_register_script('circle_custom_script', plugins_url('skill_bar/circle/custom.js', __FILE__), , array('jquery'));
    		wp_enqueue_script('circle_custom_script');
    
    		wp_register_script('gage_script', plugins_url('skill_bar/gage/justgage.1.0.1.min.js', __FILE__), , array('jquery'));
    		wp_enqueue_script('gage_script');
    
    		wp_register_script('gage_raphael_script', plugins_url('skill_bar/gage/raphael.2.1.0.min.js', __FILE__), , array('jquery'));
    		wp_enqueue_script('gage_raphael_script');
    	}
    }
    Plugin Author SKTThemes

    @sonalsinha21

    Hi GJK,

    But i released a new version 1.1 and there is no need to edit any code.

    It is working fine with 3.8, 3.7.1 on all the themes we checked.

    Please let me know if the latest version 1.1 is working for all of you since we have updated the plugin.

    Hello. I’ve tried what you told me to do, but it still doesn’t work.
    any other suggestions? Thanks!

    http://sominheo.com/about/

    I downloaded version 1.1. Works like a charm! Thanks..

    Plugin Author SKTThemes

    @sonalsinha21

    Hi Sominheo,

    So did you try GJK edit or did you updated plugin to version 1.1?

    Can you let us know because yesterday we tested version 1.1 on 27 sites and it worked just fine

    Hi. I tried both actually, but both didn’t work out for me.
    and now I updated wordpress version 3.8 to 3.8.1. maybe that’s why it didn’t work on mine? I’m not sure..

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] JQuery animation doesnt work (bar mode)’ is closed to new replies.