WordPress.org

Support

Support » Plugins and Hacks » [Resolved] jquerey error after wordpress 3.6 update

[Resolved] jquerey error after wordpress 3.6 update

  • bball349
    Member

    @bball349

    After updating to wordpress 3.6, Comprehensive Google maps stopped working. I have verified on another site that the plugin works properly before the 3.6 update but stops working after. Please help!!!!

    I get the error message below:

    “ATTENTION! (by Comprehensive Google Map Plugin)

    Your blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0.
    The Comprehensive Google Map plugin will not work with such outdated jQuery version.

    The minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience.”

    Please help!!!

    http://wordpress.org/plugins/comprehensive-google-map-plugin/

Viewing 15 replies - 46 through 60 (of 91 total)
  • NickAndy
    Member

    @nickandy

    Thanks drtonyb. Working fine on my site. Thanks for the code and the clear directions!

    theshine
    Member

    @theshine

    ponderconsulting, not sure why you got that error, possibly you commented out too much. Glad you got it working, I’m going to try the framework.js fix now.

    cu3ba11
    Member

    @cu3ba11

    Good one drtonyb. I uninstalled the plugin and modified assets/js/cgmp.framework.min.js

    m=parseFloat(a.fn.jquery);if(1.3>m)return alert(i.oldJquery),!1;

    to

    parseFloat(a.fn.jquery);if(/1\.[0-2]\.[0-9]{1,2}/.test(a.fn.jquery)>m)return alert(i.oldJquery),!1;

    And it worked perfectly!

    theshine
    Member

    @theshine

    I’ve tried all the fixes in this post, but I’m still having trouble with the plugin. Anyone want to look at the <head> on this page for other possible conflicts.
    http://www.culinarybackstreets.com/shanghai/2013/yuyang-laozhen/

    I haven’t yet tried to turn off every plugin and then retest. Right now I’m suppressing the error message, but maps still won’t load.

    Thanks

    drtonyb
    Participant

    @drtonyb

    thesunshine,

    You are loading two versions of jQuery for starters (not a good idea) – version 1.6.4 from google’s CDN and 1.10.2 from your local wordpress installation.

    Error in your modification of assets/js/cgmp.framework.min.js

    //if(/1\.[0-2]\.[0-9]{1,2}/.test(a.fn.jquery))

    should be

    if(/1\.[0-2]\.[0-9]{1,2}/.test(a.fn.jquery))

    The // is a comment and removes a lot of code.

    theshine
    Member

    @theshine

    drtonyb I commented out the check version line (I added the “//” on purpose) because the code you suggested wasn’t working for my install, so I thought I might have some luck with no check version at all. I’m pretty sure 1.64 is coming from a different plugin (that I haven’t yet deduced). I was thinking if I had no version checks, the thing might work, but it doesn’t. I’ll add back the jq version checks, you’ll see that it still doesn’t work. My next thought was to use a filter to change or remove the call to 1.10.2.

    drtonyb
    Participant

    @drtonyb

    sunshine,

    Your comment // in minimised code like this comments out the entire line which removes more code than just one statement.

    I think jQuery 1.6.4 might be coming from your slider plugin

    stopczas
    Member

    @stopczas

    Thank you Michael from coastlog.net and daviz

    ind the line

    if(1.3>m)return alert(i.oldJquery),!1;

    and change it to:

    if(1.1>m)return alert(i.oldJquery),!1;

    Then open the file assets/js/cgmp.framework.js

    Find

    var version = parseFloat($.fn.jquery);
    if (version < 1.3) {

    and change that to:

    var version = parseFloat($.fn.jquery);
    if (version < 1.1) {

    I did what Michael said, but it still was not working,
    then i changed to 1.1 like daviz wrote

    >Anyway, I’d rather prefer to write
    if (version < 1.3 && version != 1.10)
    instead of downgrade plugin to jquery 1.1

    So those two instruction works perfectly at elkomp-komputery

    theshine
    Member

    @theshine

    drtonyb the comment is gone, the map is still not working. The jquery check still fails. The second jquery include in my theme was hard coded into the head, which I also removed, but that breaks the slider and doesn’t fix the map. For some people, code like this might work in functions.php (if you don’t want to hack the .js files).

    if(!is_admin()){
    	wp_deregister_script('jquery');
    	wp_register_script('jquery', ("https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"), false, '1.8.3');
    	wp_enqueue_script('jquery');
    }

    This will put your jquery back to 1.8.3 which was the version included in WP 3.5.

    usacoop
    Member

    @usacoop

    Thank you………….. easy to edit. works fine now..

    Quick workaround:

    You need to edit the file assets/js/cgmp.framework.min.js

    Find the line

    if(1.3>m)return alert(i.oldJquery),!1;

    and change it to:

    if(1.1>m)return alert(i.oldJquery),!1;

    Then open the file assets/js/cgmp.framework.js

    Find

    var version = parseFloat($.fn.jquery);
    if (version < 1.3) {

    and change that to:

    var version = parseFloat($.fn.jquery);
    if (version < 1.1) {

    That should do the trick…

    Regards,

    Michael

    theshine
    Member

    @theshine

    I tried making the various changes to framework.js code, but the only thing that worked for me was deregistering and reregistering jquery with another version in functions.php. (See my previous response.)

    decisive
    Member

    @decisive

    Is this plugin no longer being supported by the author?

    This plugin started showing an annoying popup after the last WP update.

    So I tried to install the JQuery Update plugin. Thant didn’t fix anything, so I turned off the Google Map plugin and tried to turn it back on. Now I’m receiving this message…

    Plugin could not be activated because it triggered a fatal error.

    I have tried using the js fix… nope
    I tried reinstalling the original plugin… nope
    I tried turning off JQuery plugin with fresh install of Maps… nope.

    Now I’ve got tons of pages on my site showing gobbily-gook code. Could really use a fix for this… Think I’ll try theshines workaround next.

    drtonyb
    Participant

    @drtonyb

    theshine,

    Are you able to put your site back to its state where the only modification is to the version check in assets/js/cgmp.framework.min.js?

    To use any version of jQuery from 1.9.0 onwards you need to include

    <script src="http://code.jquery.com/jquery-migrate-1.2.1.js"></script>

    for the map code to function without errors.

    drtonyb
    Participant

    @drtonyb

    decisive,

    Nobody can help if we can’t see your site

    tommcgee
    Participant

    @tommcgee

    Thanks, drtonyb, your solution worked perfectly. Example page: http://tom-mcgee.com/blog/archives/6857

Viewing 15 replies - 46 through 60 (of 91 total)
  • The topic ‘[Resolved] jquerey error after wordpress 3.6 update’ is closed to new replies.