Support » Plugin: WPF-jqGrid » jqGrid formatting issue

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author faina09


    I experienced the same issue using theme twentyfourteen but cannot solve the problem 🙁
    Have you tried my plugin? Do you want to contribute to develop?

    I recently installed your plugin but I don’t want to get too far into it and then find out that it may not have the functionality I need?
    Are you using the entire jqGrid library so I can call any method? Is there a list of the functionality it has at this time compared to jqGrid?

    I’m still getting acquainted with the grid so probably wouldn’t be able to make a good contribution yet.

    Thanks for creating your version, it looks pretty slick.

    Plugin Author faina09


    ALL the features of jqGrid are virtually implemented in WPF-jqGrid.
    It is simply a wrapper, plus a jscript code generator.
    From a users’ point of view it is only a problem to correctly specify the additional jscript parameters for each field: in this moment the way to do this is a little tricky, I planned to develop a more simple sistem if someone is interested.
    What are your requests?

    Regarding you problem with the first column, I am sure it is only a problem related to twentyfourteen theme: that looks pretty good but is really difficult to frame some new css feature in it! I was unable to solve the problem, probably due to my insufficient experience with advanced css

    I wonder if it’s formatted properly in twenty thirteen? In twenty fourteen I tried getting rid of the jqgrid css from trirand and the first column was still offset.

    In your wpf grid I’d like to be able to:

    a) Select a different table name. when I installed it I entered a different name but then it said “you do not have access to this table” when I tried to run the plugin. I had to reinstall it under the default settings. How can I change it in your plugin config files?

    b) In the top row of the table where the blank boxes are, I’d like to be able to have it do an autocomplete where as I type each letter it finds the substrings in the database. Also for some reason when I do type in the name of a city that exists in the database I see that the grid is loading, but it doesn’t filter the results, I still see all cities. If I click on the search button and search that way, I can search successfully but I want to be able to filter within the table.

    c) When I click on a row I’d like it to open a pop-up box/form with the existing fields to edit (but not including the hidden fields) so I can edit them in the pop-up box.

    d) I’d like to be able to get a summary of the data in the footer of the grid.

    e) I’d like to be able to have frozen rows or columns.

    f) I’d like to be able to hide columns.

    g) Ability to create custom formatting.

    h) Have subgrids so clicking on certain fields drills down and displays more detailed data. I’m not sure if this is possible when it’s combined with displaying a row when it’s clicked on in a popup form?


    Plugin Author faina09


    I use a twenty twelve theme but tested with twenty thirteen with no problems.
    I repeat: probably it is due to my poor css knowledge, but twenty thirteen is unusable if I want to do more that simple entry posts!

    My sample site has a page that olready implements your points a) b) c) f) g) I still not implemented the h) point, but I have this in a project I developed with C# and jqGrid.
    I know that for this plugin the configutation is a little tricky; I planned a more user freindly approach if I found interest and time to do.
    Using “WPF-jqGrid Configuration Options” to accomplish each of your points you must:
    a) add the table name in the “allowed tables (comma separated)” box
    b) do nothing. If it does not work please try demo first. If this works inspect you generated html.
    c) A little bit different. Click on the row, then click the pencil tool. The user must have the “role required to edit tables” specified in the plugin setup page.
    d) f) probably has to be implemented, but may be you can specify a keywork in the syntax:

    custom fields formatting (| separated) es: table::field::align:’center’,editoptions:{‘size’:40}|

    that give you the ability to have hidden fields and custom formatting [points f) and g) ]

    Please have a more deep look at the plugin setup page and at the sample page I posted below.

    By the way I notice that wpf-jqgrid is also having the same issue with misaligned columns in the twenty fourteen theme. It lines up properly in twenty thirteen though the column headers are slightly hidden.

    Plugin Author faina09


    probably my english is very bad, but I tried many times to tell you that I have had problems with twenty fourteen theme every time I tried to do something more than write a simple post. I suggest you NOT TO USE this theme

    Moderator Andrew Nevins


    Forum moderator

    @faina09, If you have problems with the Twenty Fourteen theme first create a thread in its support section and ask for help before discouraging people use it so harshly:

    Plugin Author faina09


    @andrew, sorry you’re right.
    But I pointed out before that the problem probably is simply due to my poor css knowledge, and because now we are focusing on jqGrid issues, is fool to use a theme that we do not know enough.

    Thanks for your help with the grid configuration information Faina. I’ll give it a try. It sounds like many of the things I’m looking for you already have working.

    I do like the look of the twenty fourteen theme but looks like I will have to use an older theme at this time to work with the grid. I’ve spent many hours as well trying to figure out what is causing the problem. Meanwhile I’ll post in the twenty fourteen forum to see if people can shed some light on the problem. I continued to post on this thread since I figured you would be the best person to ask about grid issues since you’ve got your own, and also be really interested in what might be causing these weird problems.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘jqGrid formatting issue’ is closed to new replies.