Support » Plugin: EWWW Image Optimizer » jpegtran not working

  • Resolved tbrockdorf


    I tried to download jpegtran automatically. It failed. Automatic update message “jpegtran was not installed, check permissions on the wp-content/ewww folder.” The permissions are the same as the optipgn and gifsicle, which installed and worked.

    I downloaded jpegtran manually, placed it in the directory with the same permissions as optipgn and gifsicle and it is not recognized in the plugin.

    Any ideas?

    jpegtran: MISSING Install automatically | manually
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick ‘convert’: OK
    safe mode: Off  exec(): OK  shell_exec(): OK  
    Only need one of these: finfo: OK  getimagesize(): OK  mime_content_type(): OK

    Debug Info

    jpegtran path:
    optipng path: /services3/webpages/util/t/o/
    gifsicle path: /services3/webpages/util/t/o/
    pngout path:
    disabled functions: phpinfo
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    Operating environment: Linux #1 SMP Mon Dec 13 21:56:57 EST 2010 i686

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nosilver4u


    try downloading this one:

    When you upload it, rename it to jpegtran-custom and adjust the permissions to match optipng and gifsicle like you did with the other one.

    Same result…still not seeing it. Is there a way to manually specify the jpegtran path?

    Plugin Author nosilver4u


    nope, it isn’t necessary anymore, it checks both those locations automatically. If it doesn’t detect it, it usually means that the binary can’t run on your server. I’ve got one other person having trouble with jpegtran too, and I’ve been trying to figure that one out.

    The fact that optipng and gifsicle work is encouraging, but I need to try and find a way to make jpegtran truly ‘static’ (no dependencies). It doesn’t seem to be quite as simple as the others.

    Plugin Author nosilver4u


    Ok, after much research, it isn’t possible to make jpegtran any more static than it is. If you have ssh/shell access we can try and do some digging to get more information on why it isn’t working.

    Otherwise, there’s a couple other things you can check. First, you can ask your webhost if they have jpegtran installed on your server. If not, also ask them if they can test the jpegtran binary installed in wp-content/ewww/ to see if it runs properly.

    Something like this should do it:
    /services3/webpages/util/t/o/ -v

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘jpegtran not working’ is closed to new replies.