EWWW Image Optimizer
[resolved] jpegtran not updating (7 posts)

  1. Android63
    Posted 3 years ago #

    The plugin status page says there's an update available for jpegtran. When I try to install automatically, the message "jpegtran was successfully installed" is shown even though jpegtran doesn't update.

    I'm running on 64-bit Ubuntu 12.04 LTS on an Amazon EC2 instance with Nginx. The details are as follows:

    Plugin Status

    If updated versions are available below, you may need to enable write permission on the wp-content/ewww folder to use the automatic installs.
    *Updates are optional, but may contain increased optimization or security patches

    jpegtran: UPDATE AVAILABLE* Install automatically | manually version: Based on Independent JPEG Group's libjpeg, version 8b 16-May-2010
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    pngout: OK version: May 30 2012
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  
    Only need one of these: finfo: OK  getimagesize(): OK  mime_content_type(): OK
    Debug Info

    jpegtran path: jpegtran
    optipng path: /var/www/wordpress_238902/wp-content_327434/ewww/optipng
    gifsicle path: /var/www/wordpress_238902/wp-content_327434/ewww/gifsicle
    pngout path: /var/www/wordpress_238902/wp-content_327434/ewww/pngout-static
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0775
    user: www-data
    Operating environment: Linux 3.2.0-37-virtual #58-Ubuntu SMP Thu Jan 24 15:48:03 UTC 2013 x86_64

    > whereis jpegtran
    jpegtran: /usr/bin/jpegtran /usr/bin/X11/jpegtran /usr/share/man/man1/jpegtran.1.gz
    > ldd /usr/bin/jpegtran
    linux-vdso.so.1 => (0x00007fffdda9f000)
    libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007fe3aab87000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fe3aa7c8000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fe3aade4000)


  2. nosilver4u
    Plugin Author

    Posted 3 years ago #

    I think you may have just given me a good lead on fixing this issue. I've tried it on a server at work that is running the same OS as yours, and it gives me an odd error, so I'll see what I can figure out.

  3. Android63
    Posted 3 years ago #

    OK, great. Let me know if I can do anything to help.

  4. nosilver4u
    Plugin Author

    Posted 3 years ago #

    I'm still working on 1.4.0, and the new binary will be included there, but if you want to get a jump-start on things, I've uploaded the new version of jpegtran here:

    Put it in the wp-content/ewww/ folder, and name it jpegtran-custom and see if that works. If you use ftp to upload it, make sure you are in Binary mode, or it will likely not work at all.

  5. Android63
    Posted 3 years ago #

    Yes, once I set the ownership and permissions right, it worked.

    Thanks Shane.

  6. nosilver4u
    Plugin Author

    Posted 3 years ago #

    released 1.4.0 with updated jpegtran, let me know if it works or doesn't

  7. Android63
    Posted 3 years ago #

    Yep, that works. Thanks Shane.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • EWWW Image Optimizer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic