Support » Plugin: EWWW Image Optimizer » jpeg tran installed but not recognized?

  • Resolved Felix



    the debug info indicates that jpegtran is installed but it still says “jpegtran is missing”

    Here is the debug:

    jpegtran version: Independent JPEG Group's JPEGTRAN, version 6b 27-Mar-1998
    optipng version:
    gifsicle version:
    pngout version:
    GD: OK
    Imagemagick convert installed: NO
    safe mode: Off
    Operating System: Linux
    exec(): enabled
    getimagesize(): OK
    mime_content_type(): missing

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author nosilver4u


    The current solution for such a problem is to simply check the box next to ‘Skip utils check’.

    HOWEVER, the next version (1.3.0) has a completely revamped (and more secure) ‘utils check’ so that hopefully you can uncheck that option and everything will work properly. I expect it to be out before Christmas, but certainly before the first of the year. If you’ll leave this thread open, I’ll post a reminder here to see if the new version works better for you after it is released.

    One last thing, would you mind letting me know what specific operating system you are running (if you know or can find out)? I’m a bit curious as to how to replicate the situation if I can. Is it an older version of CentOS, or RHEL? Debian, Ubuntu. If you don’t feel comfortable posting it here, you can use the contact form on my website (

    Hey, thanks for your fast reply and sorry for the doublepost. I actually did check “Skip utils check” and then tried to optimize some images.

    I don’t get any error messages. However, the optimization will take “0 seconds” and produce “No savings”.

    Might that have something to do with the missing mime type?

    Sadly my server skills are not very advanced, so I don’t know if I can find out the OS but I’ll try

    Plugin Author nosilver4u


    released 1.3.0 today that includes a completely revamped ‘utils check’.

    I’m a little puzzled by your second post though. It would appear from your description that you selected multiple images on the Media Library page, and then selected Bulk Optimize from the actions menu. With JPG’s, the optimization is rather quick, but if they are actually missing the mimetype as you mention, then the results you saw may be due to a couple bugs I cleaned up in 1.3.0 as well. At any rate, try the new version, and see how you fare.

    Thanks for your answer!

    Sadly, I still experience the same problem. The status report gives an “OK” on everything except for “mime_content_type(): MISSING”.

    The processing will still “work” but there won’t be any savings.

    This is true for original uploads, bulk optimization and single optimization (tested with unoptimized large jpgs).

    Plugin Author nosilver4u


    Ah, I’m following you a bit closer, but it should actually show savings if there are any to be seen.

    If it was unable to determine the mimetype, it ought to give you a warning on the Media Library saying something like Unknown file type or Unsupported file type. The mime_content_type function is actually a fall-back and isn’t really supported anymore by PHP (it still exists in most installs though). Do you see No Savings on EVERY jpg you upload? Can you give me a link to an un-optimized jpg so I can test it for myself?

    Otherwise, you can use the test jpgs in this file from the JPG developers:

    The last suspicion I have is that perhaps your server somehow prevents output redirection which is necessary for jpegtran to function. It differs from processing of PNG and GIF images in that regard, so I’d be curious to see if your server will allow you to optimize any PNG or GIF images. You could download the logo from the gifsicle site –

    Ironically, the logo isn’t optimized, so you should see something like a 3.2 KB reduction on it.

    I tried installing pngout and gifsicle for testing if they would work (I don’t actually need them).

    However, EWWW did not recognize them.

    Also, since the last update, it says, that there is an update for jpegtran which I also can’t seem to get working either by manual or automatic installation.

    It’s probably something with the server. Thanks for helping nevertheless!

    Plugin Author nosilver4u


    The jpegtran update is optional, so no worries there.
    Try turning on DEBUG mode in your wp-config.php and see if it sheds any light on the subject.

    optipng and gifsicle should be auto-installing themselves, can you paste the plugin status section from the latest version of the plugin?

    Also, If you look in the source for the page near the Plugin Status section, you will see the file paths that the plugin has detected (I’ve hidden them from displaying so they don’t clutter up the page). Can you also paste those here?

    Plugin Author nosilver4u


    Just found a bug with jpegtran and shell_exec() in 1.3.5 that could have caused your problems, releasing a fix tonight (hopefully).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘jpeg tran installed but not recognized?’ is closed to new replies.