Support » Plugin: Jetpack by WordPress.com » JP 4.7: Official Facebook and Google+ Button do not show

  • Resolved MarkRH

    (@markrh)


    After updating to WordPress 4.7.3 I noticed that my posts only showed the Twitter share button. The Facebook and Google+ ones were gone (I only use these 3). I checked the settings and changed the button style to “Icon+Text” and I could then see the buttons. Changed it back to the Official buttons and they disappeared on the posts again. For now, I’ve set the back to “Icon+Text” which do seem to load faster so I may just keep it at that.

    Not 100% sure if Jetpack 4.7 or WP 4.7.3 caused the issue.

    • This topic was modified 2 weeks, 5 days ago by MarkRH.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Could you switch back to Official Buttons for a few minutes, and then post your site URL here so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thanks!

    I’ve changed them back. The buttons are only on the posts, not the main page, so here’s a post: http://blog.markheadrick.com/2017/01/28/galleries-updated-to-zenphoto-v1-4-14/

    Plugin Author Jeremy Herve

    (@jeherve)

    Thanks!

    The necessary libraries don’t appear to be added to your site’s footer. The Twitter button only works because you’re using other elements that load the Twitter libraries on your site.

    Could you try to deactivate all plugins that may affect the way resources are enqueued and added to your site, and anything that may customize the way sharing buttons are loaded, like the Jetpack Extras plugin you’re using on your site?

    Let me know how it goes.

    Yeah, looks like Custom Tweaks for Jetpack by BarryCarlyon is causing it. Should of thought about checking that. If I disable it, then buttons appear. Perhaps you guys can add the options to Jetpack itself to control where the buttons are placed. 🙂

    Anyway, I’ll let him know.

    Thanks,
    Mark H.

    Looks like after Jetpack was updated to 4.7.1, the Official Buttons now show, even with the Custom Tweaks for Jetpack plugin enabled and the buttons moved back to the top of the post.

    Plugin Author Jeremy Herve

    (@jeherve)

    Good to know! It seems the changes we made to fix some issues on sites using jQuery in the footer also fixed the conflict with the Custom Tweaks for Jetpack plugin. Thanks for letting me know!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.