WordPress.org

Forums

BackWPup Free - WordPress Backup Plugin
Jobs sometimes reschedule to 1-jan-1970 (10 posts)

  1. Chantal Coolsma
    Member
    Posted 2 years ago #

    I have scheduled jobs on different sites on different servers, but sometimes jobs simply don't run anymore. When I checked the last runtime, I noticed they were rescheduled to 1-jan-1970. Since that is in the past, they won't run anymore until you reschedule them.

    Any ideas how to solve?

    http://wordpress.org/extend/plugins/backwpup/

  2. Chantal Coolsma
    Member
    Posted 2 years ago #

    Any news on this problem? I can't rely on scheduled backups at the moment.

  3. Juanfrito
    Member
    Posted 2 years ago #

    Hi Chantal,

    It also happens to me. I have three sites running, one of them multisite.

    Every site with same WP and BackWPup version, but multisite is the only one that behaves like that, every job rescheduled to 1-jan-1970. ¿could it be server issue?

    I've tried to trigger the job using cron and setting the job's schedule to start it with a link, but so far with no luck, wget outputs nothing

  4. Chantal Coolsma
    Member
    Posted 2 years ago #

    Hi Juanfrito,

    I also have it on singlesite installs. Just checked. Multisite rescheduled fine, singlesite was rescheduled to 1 jan 1970.

    Both running version 3.0.12.

  5. biberkopf
    Member
    Posted 2 years ago #

    I have just experienced the same: one of two jobs was set to execute at 1/1/1970 02:00 (WP-Cron) in the jobs lists.

    When I clicked edit to checkt the settings in the schedule tab it was correctly set to next Friday. So I presume the script would have run correctly and that the wrong date in the list was merely a glitch.

    I tried to change the time and also toggle back and forth between wp-cron and manual in the schedule tab, saving a couple of times in the process.

    This seemed to solve the problem. Not sure if it was the time change or the mode change that did the trick.

    (There were some ftp-deletion of a big subfolder going on in the background while all this was taking place. Perhaps this activity could also have confused the script, since I have asked BackWPup to "display folder sizes on Files tab if job is edited".)

  6. Michael Nordmeyer
    Member
    Posted 1 year ago #

    I have the same problem. Because of the time being in the past no scheduled backup will run.

    Navigating to the scheduling tab and saving seems to remedy this problem as long as I don't touch any other BackWPUp settings or work with BackWPUp in any other way manually afterwards.

    The last successful backup before experiencing this behavior was June 26th.

  7. whites7
    Member
    Posted 1 year ago #

    I'm getting the same issue too. Shame there is no response on how to fix yet. I have tried using alternative chron but doesn't help

  8. mbrsolution
    Member
    Posted 1 year ago #

    Hi, if you read the FAQ you will see some information in regards to your issue.

    My backup jobs don’t seem to run as scheduled.

    BackWPup uses WordPress’ own cron job system (WP Cron) to execute scheduled backup jobs. In order for WordPress to “know” when to execute a job, its “inner clock” needs to be set regularly. That happens whenever someone (including yourself) visits your site. If your site happens to not being visited for a period of time, WordPress’ inner clock gets sort of slow. In that case it takes an extra server-side cron job to regularly call http://your-site.tld/wp-cron.php and tell WordPress what time it is.

    A simple way to find out whether WP Cron works as it should on your site is to create a new post and set its publishing date to some point in the future, i.e. 10 minutes from now. Then leave your site (that’s important), come back after 11 minutes and check whether your scheduled post has been published. If not, you’re very likely to have an issue with WP Cron.

    You might have a WP Cron issue.

    You might want to try the following plugin WP Control, to check what cron job is running.

    I hope the above puts you on the right track to solving your issue.

    Kind regards

  9. Michael Nordmeyer
    Member
    Posted 1 year ago #

    My 1 Jan 1970 problem was solved when updating to WordPress 3.6 release version. I was running 3.6 RCx before.

  10. MtGamberWesbiteDesign
    Member
    Posted 1 year ago #

    I'm on WordPress 3.6.1. with a single site and this is happening to me too. I have to schedule 6 jobs so that the jobs don't time out and yet 2 of them (and only 2 of them) reschedule to 1970.

    If it was a cron job issue why would only 2 of them re-schedule to 1970?

    Cheers,
    Karen

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags