Support » Plugin: BackWPup - WordPress Backup Plugin » Job $s has started, but not responded for 10 seconds.

  • Resolved Zoker

    (@zoker)


    Hi there,

    Since some days, I get the following issue, when I manually run my backup job:

    I get this error on many sites, but they have a similar setup.

    I also noticed following errors in the debug log:

    PHP Warning:  Illegal string offset 'run' in /wp-content/plugins/backwpup/inc/class-cron.php on line 133
    PHP Warning:  Illegal string offset 'nonce' in /wp-content/plugins/backwpup/inc/class-cron.php on line 137
    PHP Warning:  Illegal string offset 'jobid' in /wp-content/plugins/backwpup/inc/class-cron.php on line 141
    PHP Warning:  array_merge(): Argument #2 is not an array in /wp-content/plugins/backwpup/inc/class-cron.php on line 145

    I’m not sure, if they are causing the issue.

    Here is the info from the information tab:

    WordPress version	4.7.1
    BackWPup version	3.3.4 Get pro.
    PHP version	7.1.0 (64bit)
    MySQL version	5.6.35
    cURL version	7.19.7
    cURL SSL version	NSS/3.21 Basic ECC
    WP-Cron url:	https://site.com/wp-cron.php
    Server self connect:	Not expected HTTP response:
    Status-Code: 200
    Date: Sun, 15 Jan 2017 12:45:01 GMT
    Server: Apache
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-control: no-store, no-cache, must-revalidate
    Pragma: no-cache
    Set-cookie: PHPSESSID=633b09afb14d632b396630b8ec854d77; path=/
    Vary: Accept-Encoding,User-Agent
    Content-encoding: gzip
    Content-length: 20
    Content-type: text/html; charset=UTF-8
    Temp folder:	/wp-content/uploads/backwpup-35e9ea-temp/
    Log folder:	/wp-content/uploads/backups/logs/
    Server	Apache
    Operating System	Linux
    PHP SAPI	cgi-fcgi
    Current PHP user	sub3995_23
    Maximum execution time	60 seconds
    Alternative WP Cron	Off
    Disabled WP Cron	Off
    CHMOD Dir	493
    Server Time	12:45
    Blog Time	13:45
    Blog Timezone	
    Blog Time offset	1 hours
    Blog language	en-US
    MySQL Client encoding	utf8
    Blog charset	UTF-8
    PHP Memory limit	512M
    WP memory limit	512M
    WP maximum memory limit	512M
    Memory in use	16.00 MB
    Loaded PHP Extensions:	Core, PDO, PDO_ODBC, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, readline, session, shmop, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

    Because of security, I changed the url in the “WP Cron” field.

    Even having a clean htaccess file does not help.

    If you need any further information, let me know!

    • This topic was modified 2 years, 5 months ago by  Zoker.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Ok, seems to be a php 7.1 error, works good with 7.0

    Hello,

    I have the same problem, when I manually run my backup job I’m getting this error:

    Job "Full backup" has started, but not responded for 10 seconds. Please check information.

    Here is the data from the Information tab:

    WordPress version	4.7.1
    BackWPup version	3.3.4 Get pro.
    PHP version	7.1.0 (64bit)
    MySQL version	5.6.33-log
    cURL version	7.29.0
    cURL SSL version	NSS/3.19.1 Basic ECC
    WP-Cron url:	/wp-cron.php
    Server self connect:	Not expected HTTP response:
    Status-Code: 200
    Date: Mon, 16 Jan 2017 09:44:43 GMT
    Server: Apache
    Cache-control: max-age=3600
    Expires: Mon, 16 Jan 2017 10:44:43 GMT
    Vary: User-Agent
    Content-length: 0
    Content-type: text/html; charset=UTF-8
    Temp folder:	/uploads/backwpup-a32387-temp/
    Log folder:	/uploads/backwpup-a32387-logs/
    Server	Apache
    Operating System	Linux
    PHP SAPI	cgi-fcgi
    Current PHP user	
    Maximum execution time	30 seconds
    Alternative WP Cron	Off
    Disabled WP Cron	Off
    CHMOD Dir	0755
    Server Time	9:44
    Blog Time	10:44
    Blog Timezone
    Blog Time offset	1 hours
    Blog language	en-US
    MySQL Client encoding	utf8
    Blog charset	UTF-8
    PHP Memory limit	268435456
    WP memory limit	40M
    WP maximum memory limit	256M
    Memory in use	24.00 MB
    Loaded PHP Extensions:	Core, PDO, Phar, Reflection, SPL, SimpleXML, cgi-fcgi, ctype, curl, date, dom, filter, ftp, gd, hash, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, readline, session, soap, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

    I cannot downgrade PHP to v7.0, that is not a option.

    I really appreciate any help you can provide.

    Regards

    • This reply was modified 2 years, 5 months ago by  Milos Spasic.
    rnikolaenkov

    (@rnikolaenkovgmialcom)

    And that’s not the version of WordPress. The situation is similar with WordPress 4.6.2

    Chiming in 🙂 Strangely, several sites on the same server, a couple fail with this error. Others works fantastic. Go figure.

    Not expected HTTP response:
    Status-Code: 200
    Server: nginx/1.10.2
    Date: Mon, 16 Jan 2017 23:05:11 GMT
    Content-type: text/html; charset=UTF-8
    Content-length: 20
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-cookie: Array
    Vary: Accept-Encoding
    Content-encoding: gzip
    Plugin Author Christina Fuchs

    (@vanvox)

    @all we are currently working on the php 7.1 compatibility issues and there will be an update in a few days.

    Awesome. I’ll send you some money. Where can I send it to?

    Hello,

    i have the same problem with PHP 7.1.

    Do you have any updates on the issue?

    Thanks in advance.

    Plugin Author Christina Fuchs

    (@vanvox)

    Hi @all,

    we have released a new BackWPup version and fixed php 7.1 incompatibilities. You can find more info about the new version 3.3.6 in our blog: https://backwpup.com/backwpup-version-3-3-6-now-available-php-7-1-compatibility/

    Cheers
    Christina

    That’s a great news! Thanks a lot.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Job $s has started, but not responded for 10 seconds.’ is closed to new replies.