Support » Plugin: WP Job Manager » Job listings doesn’t appear at second/english page

  • Resolved othisiadmin


    I ve used the shortcode [jobs] for the Career Openings page and while it works perfectly on the Greek edition, In the English one it just shows the search bar and the message “There are no listings matching your search.”.

    Note: the translated pages refer just to text on the page and not on the job listings.

    How can I fix it?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Richard Archambault


    Hi! I took a look at your site, and I can’t determine what you’re using for the multilingual functionality. What plugin are you using?

    Thread Starter othisiadmin



    Plugin Author Jake Morrison


    Hi there! This is more of a Polylang customization. It sounds like you’re trying to disable the ability to have multiple languages for job listings. You can try starting with this snippet to do that for job listings:

    add_filter( 'pll_get_post_types', function ( $post_types ) {
        unset( $post_types['job_listing'] );
        return $post_types;
    } );
    remove_filter( 'wpjm_lang', 'polylang_wpjm_get_job_listings_lang' );
    remove_action( 'get_job_listings_query_args', 'polylang_wpjm_query_language' );

    If you paste that into your theme’s functions.php or using the Code Snippets plugin, that might help accomplish what you’re trying to do. I’m not sure how much more we can support with this, but Polylang has some documentation on their filters here:

    Hope that helps!

    • This reply was modified 1 year, 10 months ago by Jake Morrison.
    Plugin Contributor Richard Archambault


    I’m marking this thread as Resolved as it’s been more than a month since the last reply. If you still need help, please do reply again and mark the thread as Unresolved!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Job listings doesn’t appear at second/english page’ is closed to new replies.