Support » Plugin: BackWPup - WordPress Backup Plugin » Job does not responded for 10 seconds after migration to https:

  • Resolved Ger

    (@lindt01)


    Hi,

    Before migrating a customer site to https:// I made a backup via wp-cron.php and it worked ok. After migrating to https:// BackWPup via wp-cron.php gives this error:

    Job “Test_Job_BU” has started, but not responded for 10 seconds. Please check information.

    Information file is as follows:

    WordPress version: 4.9.5
    BackWPup version: 3.4.5
    PHP version: 7.0.29 (64bit)
    MySQL version: 5.7.21-20-log
    cURL version: 7.54.0
    cURL SSL version: OpenSSL/1.0.2k
    WP-Cron url: https://www.kokenmetkarin.nl/wp-cron.php
    Server self connect: Not expected HTTP response:
    Status-Code: 404
    Date: Mon, 23 Apr 2018 15:56:35 GMT
    Server: Apache/2
    Content-length: 328
    Content-type: text/html; charset=iso-8859-1
    Content: <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>404 Not Found</title>
    </head><body>
    <h1>Not Found</h1>
    <p>The requested URL /wp-cron.php was not found on this server.</p>
    <p>Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    </body></html>

    Document root: /home/kokenmetk/domains/kokenmetkarin.nl/public_html
    Temp folder: /home/kokenmetk/domains/kokenmetkarin.nl/public_html/wp-content/uploads/backwpup-b909a6-temp/
    Log folder: /home/kokenmetk/domains/kokenmetkarin.nl/public_html/wp-content/uploads/backwpup-b909a6-logs/
    Server: Apache/2
    Operating System: Linux
    PHP SAPI: litespeed
    Current PHP user: kokenmetk
    Maximum execution time: 1800 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 15:56
    Blog Time: 17:56
    Blog Timezone: Europe/Amsterdam
    Blog Time offset: 2 hours
    Blog language: en-US
    MySQL Client encoding: utf8
    PHP Memory limit: 256M
    WP memory limit: 40M
    WP maximum memory limit: 256M
    Memory in use: 36.00 MB
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apcu, bcmath, bz2, calendar, ctype, curl, date, dba, dom, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imagick, imap, intl, json, libxml, litespeed, mbstring, mcrypt, mysqli, openssl, pcntl, pcre, pdo_dblib, pdo_mysql, pdo_sqlite, posix, pspell, readline, session, shmop, soap, sockets, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    I asked the hosting provider to help me but they say nothing changed on their server and they can not help me any further.

    I defined the parameter ALTERNATE_WP_CRON in wp-config.php and set it to ‘TRUE’. Then the backup runs when choosing the schedule manually only or via a link. But not through wp-cron.php

    Can you please assist and advise me.

    Thanks in advance.
    Kind regards,
    Ger van de Lindt

    https://wordpress.org/plugins/backwpup/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author duongcuong96

    (@duongcuong96)

    @lindt01
    Could you please uninstall BackWPUp and then reinstall and try again?
    Thanks!

    @duongcuong96

    I already tried that a couple of times but just deleted and reinstalled again. The result is the same.

    Thanks!
    Ger

    Plugin Author duongcuong96

    (@duongcuong96)

    @lindt01
    Seems really weird :/

    the backup runs when choosing the schedule manually only or via a link.

    So you were unable to set automated scheduled job working?

    @duongcuong96
    Thank you for your answer. Yes, after defining the parameter ALTERNATE_WP_CRON in wp-config.php to TRUE I can run a manual backup and through the link but am unable to schedule.

    Something else: scheduling posts also does not work. I installed the plugin WP-Cron Status Checker and that also gives a 404 error:

    While trying to spawn a call to the WP-Cron system, the following error occurred:
    Unexpected HTTP response code: 404 

    My host asked me to ask you which port is used when BackWPup starts wp-cron.php

    Thanks again,
    Ger

    Plugin Author duongcuong96

    (@duongcuong96)

    @lindt01
    it’s really didn’t related to BackWPUp because you already using another plugin ( Cron Status Checker ) and still got the 404 error πŸ™‚
    So I would suggest you set the job run with a link then set up a server cron or an online cron service like cron-job.org to make it run in the correct scheduled time πŸ™‚

    Plugin Author duongcuong96

    (@duongcuong96)

    @lindt01

    since we haven’t heard back from you, I’m going to mark it as resolved.
    If you’re still having problems, feel free to let us know ;),

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support πŸ˜€
    https://wordpress.org/support/plugin/backwpup/reviews/

    @duongcuong96

    Thanks for your message. Today I learned from my hosting party that the issue is caused by a wrong configuration on their server. They serve port 80 for https:// which should actually be port 443. BackWPup makes a self connection on port 443 and that is why we get a 404 error. Perhaps this is something others having the same issue to ask their hosts!

    Please mark the issue as resolved.

    Kind regards,
    Ger

    Plugin Author duongcuong96

    (@duongcuong96)

    @lindt01
    Good to hear that it’s working for you

    If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating in here
    https://wordpress.org/support/plugin/backwpup/reviews/
    Thank you!! πŸ˜€

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.