Support » Plugin: Bullhorn Career Portal WordPress Plugin » Job Details Not Responsvie

  • Resolved sabell

    (@sabell)


    The job details page is not responsive on mobile. And you are not able to scroll over to see the items that are being cut off. My team has searched through other topic solutions and tried styling the page ourselves but nothing is helping the situation.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author charlesabarnes

    (@charlesabarnes)

    What Items are getting cut off?

    Can you possibly provide a screenshot of the issue you are experiencing?

    I don’t see anywhere on here that I can attach an image, but the apply button is extending off the screen along with all the text after that. So for the text, it is needing to wrap so its not getting cut off. But any styling to this particular page does not get implemented.

    Plugin Author charlesabarnes

    (@charlesabarnes)

    This is what I see when I attempt to view it. It seems to work fine here

    https://i.imgur.com/fO9Hapj.png

    Self-promoting ad: Look at Matador plugin as it inherits the responsive from the theme

    By viewing the page on a desktop web browser, I was able to increase the zoom between 150-175% to get the button and text to cut off. That’s what it looks like on mobile device.

    Plugin Author charlesabarnes

    (@charlesabarnes)

    It’s likely due to having “desktop mode” enabled on your mobile device, zoom doesn’t define viewport width so we would be unable to be responsive based on that. Please try seeing if there is a “desktop mode” available and disabled on your device.

    However, I am unable to reproduce as well with the zoom really high either.

    If you view this page directly do you see the same issue? https://www.getinfocus.com/wp-content/plugins/bullhorn-oscp/

    When I opened that new link on my phone, it displayed everything correctly.

    Plugin Author charlesabarnes

    (@charlesabarnes)

    I suspect it may have something to do with the styling of the iframe, where the iframe is slightly larger than the width of the page.

    I suspected that another plugin we had installed could be affecting it, so yesterday I deactivated all of them. Unfortunately, that didn’t help at all. Since I am not able to replicate this on a desktop, it’s hard to style it through a browser. Any styling I try, it will start to load correctly on mobile then it jumps back to being too big.

    Do you have a mobile device that you could view it on?

    Plugin Author charlesabarnes

    (@charlesabarnes)

    Yeah, I am viewing it through several emulators as well as multiple physical devices and I am personally not running into this issue.

    Physical Devices attempted on:

    Samsung Galaxy S9+
    Google Pixel 2
    OnePlus 3
    Motorolla Moto G2.
    iPhone 7 Plus. – showed the behavior but unfortunately it resolved itself.

    It appears as if the container the iframe is in also extends beyond the screen, and since the width is set to be 100% it causes this issue. Is it possible for you possibly adjust the width on the outer container to use vw units? Or perhaps set a
    “breakpoint” media query width for the mobile devices that you have noticed this on.

    This seems to only be happening on iPhones that are not the Plus screens. I was able to add this code to the head of the page and it fixed it. Everything is good now.

    <meta name=”viewport” content=”width=600px, height=650px” />

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.