WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Jetpack's Widget Visibility not working (37 posts)

  1. fpsdf
    Member
    Posted 1 year ago #

    Widget Visibility is a great feature but there's something not working in an experience I'm making with Twenty Thirteen:

    Defining a widget's visibilty as "Show if Page is Blog" results in it not appearing in this Blog page.
    At first it worked, but suddenly I can't make a widget appear only in Blog page.

    Anyone getting the same thing?

    Thanks!

    http://wordpress.org/plugins/jetpack/

  2. fpsdf
    Member
    Posted 1 year ago #

    Oh boy... nothing?

  3. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi!

    I tested it on my test site, and it works fine! Just a question: is the "Blog" page the name of the page? Can I have the URL?

  4. fpsdf
    Member
    Posted 1 year ago #

    Richard, thank you so much!

    Yes, I named it "Blog"...
    The funny thing is that it worked for a little bit, at the beginning.

    Sorry, it's local-dev... I would've given it to you, if I could.

  5. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Well, since I wasn't able to reproduce it, and since I can't access your site, there's not much I can do to help further at this point. If you end up finding the reason, please le tme know though! If it's a bug on our art, especially, let m eknow. Thanks!

  6. fpsdf
    Member
    Posted 1 year ago #

    I thank you. If I get to find the reason for this issue or if I make this website available online, I'll let you know!

  7. jimynd
    Member
    Posted 1 year ago #

    I am having the same trouble. I'm using the Response Theme with a static home page, Blog is the title of them blog page. If I use the visibility button and set the page to blog it doesn't display. Actually it disables the widget (archive widget) and I can't set it back to visible on all pages. I have to remove it and add a new one.

  8. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    jimy, is this the theme?

    http://www.organicthemes.com/theme/response-theme/

    If so, I can't download it to try it without buying it. Could you set things up using the widget and then give me your site's URL so I can check it out? Alternatively, could you create an admin account for me on your site so that I can try it out for myself? If yes, please send the credentials to me using our contact form:

    http://jetpack.me/contact-support/

  9. lgubernatis
    Member
    Posted 1 year ago #

    I'm having the same problem -- I'm trying to hide based on either author or on a single category. It saves the information, but it's not hiding the posts from the widget. Help?

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic.
    http://wordpress.org/support/plugin/jetpack

  11. fpsdf
    Member
    Posted 1 year ago #

    Ok, same thing happening in another site I'm developing.

    It is buggy

  12. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    'Blog' page isn't based on the page title, it should be based on the setting you've specified as the 'Posts Page' in Settings -> Reading.

    Do you have that configured?

  13. fpsdf
    Member
    Posted 1 year ago #

    Yes, it is configured as such. Been there already :)

    Thank you!

  14. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    fpsdf: did you solve the issue or are you still experiencing problems?

  15. fpsdf
    Member
    Posted 1 year ago #

    Richard, thanks for asking!

    Just checked it, updated Jetpack and it's still behaving the same way... sorry!

  16. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi! Let's get this one solved. :) Could you show me screenshots of every step in your setup (the General -> Reading page, the the Widget settings) so I can make sure everything is as it should? Alternatively, can you give me an admin account so I can log in and try things myself? You can send the credentials to me though our contact form:

    http://jetpack.me/contact-support/

  17. fpsdf
    Member
    Posted 1 year ago #

  18. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the screenshots! I know how to fix it. Rather than choosing "if Page is Blog", choose "If Page is Posts Page" at the very top, like in this screenshot:

    http://d.pr/i/i3eD

    That should fix it for you!

  19. fpsdf
    Member
    Posted 1 year ago #

    Aw god, it makes all sense...
    But I must sat I find that a bit glitchy.

  20. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You're right, you're not the first person to stumble on this issue. Any suggestions on how to have made it clearer?

  21. fpsdf
    Member
    Posted 1 year ago #

    Maybe the most effective solution would be getting the same result whether I'd choose "Blog" or "Posts Page" in the Visibility pane, since they're actually the same, at the giving moment.

    Or maybe merging "Blog" and "Posts Page" in the dropdown menu, making clear of that page "role".

  22. fpsdf
    Member
    Posted 1 year ago #

    But hey, thanks a lot for your help, guys!

  23. Duffy Bear
    Member
    Posted 1 year ago #

    Hi - I'm using the Mantra Theme from Cryout Creations. I use the Standard Format for all my posts. When I go into the widget area to change the selections no option to change anything appears, not even a visibility button.

    Thanks for your help!

  24. fpsdf
    Member
    Posted 1 year ago #

    Are you sure that you the module "widget visibility" activated, in Jetpack settings?

  25. dimit
    Member
    Posted 1 year ago #

    I am having the same problem as Duffy on a wordpress mu installation.
    Disabled all plugin except wordpress mu domain mapping
    Uninstalled and reinstalled jetpack and still the same

    As I looked closer it seems that I had no option to activate or deactivate any of jetpack's features

    http://i.imgur.com/MYJOk6I.png

    Are there any database tables or files that jetpack stores additional configuration?

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    @dimit: If you require assistance then, as per the Forum Welcome, please post your own topic.

  27. George Stephanis
    Automattic Lead Code Monkey
    Plugin Author

    Posted 1 year ago #

    dimit: Have you connected to a WordPress.com account? Some themes do naughty things like hide all notifications in the admin panel, including the connect nag. If you switch themes to twentythirteen, does it then let you connect?

  28. dimit
    Member
    Posted 1 year ago #

    george:it seems that there was a problem with my testing environment

    When there is a normal wordpress installation on "localhost" most modules of jetpack work without connecting.

    When using wordpress MU on a local machine there is the need to define "localhost.[something]" for the domains to work.
    Which somehow interferes with Jetpack, disabling it completely.

    Also, any unauthorized certificates (ssl) will also break the connection process.

    Tested it on a Live clean MU installation and everything works perfectly.

    Thank you very much for your fast support.

  29. Alan - Food Blogs UK
    Member
    Posted 1 year ago #

    After getting the same issue I found this post and decided to let you know how I have fixed it but, after fixing it I realised it may have been covered however,

    For me it was for an ad on one of my pages called Articles. The page "Articles" is what I wanted to "only show" the ad on and it showed on all others pages when i chose them i.e. about us, but nothing for Articles.

    The reason is my blog posts go to the Articles page and therefore the Articles page is set to Posts Page. The widget no longer bothers with Articles and requires me to use the Posts Page. This now works for me but I will update should there be any issues.

    [email address moderated - these forums do not provide support via email] if you want any help.

  30. Duffy Bear
    Member
    Posted 1 year ago #

    HI fpsdf,

    Yes, the widget was activated. I deactivated it and activated it again. I followed their exampled of the Archives widget and still no visibility button.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic