Support » Plugins and Hacks » [Resolved] Jetpack Youtube embeds

[Resolved] Jetpack Youtube embeds

  • Pre 3.5, this problem did not exist.

    You can see the problem on this post, but I’m getting PHP errors:

    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/donburn/public_html/wp-includes/functions.php on line 658
    Warning: stripos() [function.stripos]: needle is not a string or an integer in /home/donburn/public_html/wp-includes/functions.php on line 661

    These errors show up on any post with a Youtube video embedded. The weird part is that the error does not show up on the main blog page or archive index. See no errors here. The other weird part is that the error is pointing at a core WP file, not something related to any specific plug-in or file in my theme.

    I have disabled all plugins, the error goes away. I turn all of my plugins back on except Jetpack, no problem. I turn Jetpack on, it comes back.

    I have also tested this using Twenty Twelve and got the exact same problem.

    I have turned off shortcode embeds, but the issue is still there.

    It’s only my personal site and am game to trying anything anyone can think of to fix the issue.


Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Jeremy Herve


    Could you let me know how you embedded these videos?

    Did you use the shortcode, or did you just paste the video URL on a separate line?

    I notice that one of the videos appears on that blog post. Is there a difference between this video and the others?

    The one I used as an example is using the long version of the Youtube embed code. this one is using the short version of the Youtube embed code.

    I’ve tried using shortcodes and the same thing happens. I haven’t tried with the URL only.

    Saw the update to Jetpack and was excited. But it didn’t fix my issue.

    Guess it’s back to the drawboard for me to make sure it’s not my WP installs.

    Plugin Author Jeremy Herve


    Could you try to insert the video URL on a separate line, without using any shortcodes, like so:

    I hope this helps.

    Did that, no video shows up and the error code is still there.

    Recipe: Chicken & Waffles

    I tried pasting the code in using the text and visual editor. Nothing.

    Turned shortcodes back on. Didn’t help. Turned them off, nothing.

    When I paste the url directly into a post, the video doesn’t even show up and I thought that was a new feature of 3.5. I’m going to try to do a fresh install of WP and see if that helps.

    Reinstalled WP though the dashboard, didn’t help. Copied new files from a fresh download via FTP, no help either.

    Plugin Author Jeremy Herve


    Could you check if WP_DEBUG is set to true in your wp-config.php file? If so, could you set it to false on your production site?

    If that doesn’t help, could you try to disable the sharing module in Jetpack? You can find out how to disable a module here:

    Plugin Author Jeremy Herve


    Could you also make a screenshot of the Settings > Sharing page in your dashboard? It might give us some important information so we can reproduce the problem.

    WP_DEBUG wasn’t listed in my wp-config.php, so I did that. Set it to true first to make sure it was working, then set it to false. Errors still on the screen.

    I disabled the sharing module and that removed the error. I used the youtube shortcode to embed a video, still error free.

    Video embed via shortcode. And the screenshot is here.

    Let me know what else I can do to help, including access to the site via wp-admin or ftp.

    I was using the Artiss YouTube Embed plugin. I long ago removed it, but there were a few bits of it left in the database. I removed those bits (and double checked that the files were removed) and turned sharing back on. It didn’t help.

    Finally, I went through all of my plugins and disabled them except for Jetpack (with sharing enabled). The error still existed. I also tried with the Twenty Ten and Twenty Twelve themes, and the error still existed.

    I can only replicate this on 1 site and am starting to think it’s an issues with my theme. But this one is new to me. Could it be caused by custom posts or default WordPress features like custom header or background?

    Plugin Contributor Christopher Finke


    Have you tried disabling all of the Jetpack modules one-by-one and seeing which one causes the error to disappear? This can take a few minutes, but it would be very helpful.

    Plugin Contributor Christopher Finke


    Also, is the one site that you are having this problem on on a different host than your other sites? Is it running on a different version of PHP?

    Nothing but blue buttons on my jetpack. I checked after disabling each one, error did not go away until I disabled sharing.

    Same theme, different server, same issues. Same version of php. Different theme (barely different), same server, no issues.

    I’m trying to find a few minutes to replicate this on my wpengine account with this theme to see if I can replicate it. I’m starting to think that this might be an issue with a plugin that was installed and did not completely remove itself when I uninstalled it.

    Plugin Contributor Christopher Finke


    There is at least one other user experiencing the same issue (http://wordpress.org/support/topic/plugin-error-12?replies=10#post-3615666), so it’s probably not specific to your theme, but any information you can dig up is very much appreciated.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Jetpack Youtube embeds’ is closed to new replies.