Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack won’t connect to WordPress

  • Resolved casualbadger

    (@casualbadger)


    Hi, I sent this in as a support request via WP Admin 4 days ago but no response as yet (I did receive acknowledgement email).

    When I try to connect Jetpack I get the following error message:

    Error Details: The Jetpack server was unable to communicate with your site [my site URL] [IXR -32300: transport error: http_request_failed cURL error 35: Unknown SSL protocol error in connection to [my site URL] :443]

    Host GoDaddy spent an hour phone call looking into this from their end, and they tell me there’s no problem with the SSL certificate or port 443. I purchased the SSL certificate through GoDaddy, and it was installed as normal through their Managed WordPress control panel.

    Checked your list of “known conflict” plugins – I don’t have any of them installed.

    Tried deactivating all plugins except Jetpack – same error.

    Tried deactivating Avada theme, and activating Twenty Seventeen default theme – same error.

    WordPress, Avada theme, and all plugins are up to date.

    I don’t know what else to try. Any suggestions?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @casualbadger!

    For SSL protocol errors, the best first start is to check your certificate in an online diagnostic tool. I like this one:

    https://www.ssllabs.com/ssltest/index.html

    Address any issues that appear there and then try your Jetpack connection again.

    Thread Starter casualbadger

    (@casualbadger)

    Hi there, thanks for the tip. I used the diagnostic tool to check the certificate, and it’s not reporting any errors or issues at all (it gets an “A” rating).

    I had another lengthy support call with GoDaddy, and they confirmed again the SSL certificate is working fine. They directed me to use this tool https://www.sslshopper.com/ssl-checker.html – and provide Jetpack with all the serial numbers it coughs up, which show the SSL is configured and working correctly. They said it’s a Jetpack issue. I have a support ticket going with Jetpack, and did receive a reply today but whomever wrote didn’t read my email properly and told me to troubleshoot something I’ve already done, so I guess it will be another 4 or 5 days before I hear back from her. At this point I’d pay for support if I could to get this sorted out.

    • This reply was modified 4 years, 2 months ago by casualbadger. Reason: Edited after further GoDaddy support call
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Jetpack won’t connect to WordPress’ is closed to new replies.