WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Jetpack V2.1.1 interferes with button calls in admin screens

[Resolved] Jetpack V2.1.1 interferes with button calls in admin screens

  • topdawgnate
    Member

    @topdawgnate

    I am running WordPress 3.6 and a recently updated theme engine to Genesis 1.9.1. I updated the Jetpack plugin to version 2.1.1 this morning. I went into a new post screen this afternoon and none of the buttons would work (eg. add media, add tags, etc…). I disabled my Jetpack plugin and now it is working. Please advise.

    Thanks for your time and consideration,
    Nate

    http://wordpress.org/extend/plugins/jetpack/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Christopher Finke
    Participant

    @cfinke

    Can you try leaving Jetpack enabled and disabling your other plugins one-by-one and see if that has the same effect? Narrowing down any plugin conflicts will help us fix the issue faster.

    I have the same issue and have disabled all plugins with the Jetpack active and it’s still not working.

    Phoenixsong
    Member

    @phoenixsong

    I’m having the same problem: running 3.5, tried disabling all plugins and reenabling them one at a time, and Jetpack appears to be the only one that keeps parts of the admin interface from working. I get the following error in the console when I load the post/page editor:

    TypeError: e.widget.extend is not a function

    and when I try clicking some of the buttons, like the edit permalink button, I see:

    TypeError: editPermalink is not a function

    My guess is that something is interfering with the interface buttons that make Ajax calls (for example, the get shortlink button works fine because it pops up an alert). The first error, at least, seems to be a jQuery UI problem.

    Next I tried deactivating individual Jetpack components, and as far as I can tell the shortcode embeds feature is to blame—deactivate it and the problem goes away, letting me use the full editor interface as normal again. I don’t use those shortcodes on my site so leaving that disabled isn’t a problem for me, but for other people I guess it can serve as a temporary fix until the issue is resolved properly.

    Hope that information helps someone!

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    @phoenixsong Could you post your site URL here, so I can have a look?

    Phoenixsong
    Member

    @phoenixsong

    Sure.

    http://alteredorigin.net

    I assume you want to see it with the shortcode feature enabled, so I can go turn that on real quick, too.

    Plugin Author Jeremy Herve
    Jetpack Mechanic

    @jeherve

    Thanks!

    I tried to reproduce the issue on my test blog, but everything seems to be working properly on my end.
    Could you try to activate the Shortcodes module, and then deactivate all other plugins, one at a time, in order to find out if the Shortcodes conflict with another one of your plugins?

    If so, could you post a link to that plugin here, so I can try to reproduce?

    Phoenixsong
    Member

    @phoenixsong

    Sorry for the late response!

    The culprit, at least in my case, appears to be the Category Sticky Posts plugin; everything else I have activated works fine with the shortcode embeds enabled.

    Thanks for looking into this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Jetpack V2.1.1 interferes with button calls in admin screens’ is closed to new replies.