Support » Fixing WordPress » Jetpack update crashed site

  • talk2pj


    About 15 hours ago, I updated the Jetpack plugin, but got an error saying something like ‘Maintenance occurring; please try again in a minute.’

    After 15 mins I gave up trying, and came back to it an hour ago. Now I get this error when accessing my site:

    Warning: require_once(/home/talk2pj/public_html/blog/wp-content/plugins/jetpack/class.jetpack.php): failed to open stream: No such file or directory in /home/talk2pj/public_html/blog/wp-content/plugins/jetpack/jetpack.php on line 37

    Fatal error: require_once(): Failed opening required ‘/home/talk2pj/public_html/blog/wp-content/plugins/jetpack/class.jetpack.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/talk2pj/public_html/blog/wp-content/plugins/jetpack/jetpack.php on line 37

    My site is

    I’ve tried to FTP in to my site via Filezilla, but can’t because I get an error saying ‘login authentication failed’, even though I used my normal password.

    I’d appreciate any help you can give.



Viewing 8 replies - 1 through 8 (of 8 total)
  • Check with your hosting provider to verify that you have the right FTP settings. It sounds like the Jetpack upgrade didn’t complete properly, so you’ll need to delete the Jetpack plugin directory from /wp-content/plugins/ and reinstall it. Keep in mind, your FTP credentials are not necessarily the same as your WordPress credentials.

    Thread Starter talk2pj


    Thanks Christian. I managed to login to my site via cPanel, but don’t know my way around in there. I found various bits of advice about how to delete plugins, but some is conflicting, and I don’t want to stuff things up further. So I’ve asked an IT developer for help. I appreciate you answering my question, though.



    The latest JetPack update is failing for me as well. When I was updating other plugins were updated, so it’s not an FTP issue.



    I had the same issue. The update crashed my site twice.




    It is cystal clear from the above that the issue is not caused by the FTP settings. Follow the below guidelines to resolve the problem:
    1. The latest Jetpack version is version 2.7 and works very well if you have wordpress version 3.7 and above. So, first thing is to update your wordpress platform to the latest version i.e. version 3.8.1. To do that, go to your WP dashboard and click on update
    2. Due to some non compatibility that other plugins can be causing, you need to troubleshoot all plugins temporarily. To start, first, deactivate all plugins, save and then log off, clear your browser cache, shut down the browser, then restart ( check if the same problem occurs) 2.) Upgrade and activate only the jetpack plugin and check to see if your site will crash again. 3) the gradually, start activating each plugins back one by one.

    Try this steps, I once suffered the same fate on my blog,, and that is what I did exactly.


    I’m guessing talk2pj can’t log in to his WordPress install because he’s likely getting the error on every page load. In that case, you will need to access your server via FTP and remove the Jetpack plugin directory. This will cause WordPress to disable the plugin in its database when it sees the plugin is missing, and should let you log back in. Once you’re logged in you can install Jetpack again, and should be all set.

    Thread Starter talk2pj


    I’ve been running WP version 3.8.1 for a while, so the Jetpack crash wasn’t caused by running an out-of-date WP.

    My developer FTP-d in and disabled the Jetpack plugin. I tried to reactivate it this afternoon, and got another fatal error. At least this time my WP dashboard stayed live.

    Christian, would you suggest I delete then reinstall the plugin?

    If I do that, will I lose any stats that Jetpack has been collecting? In any case, I guess I have no choice.

    I would recommend trying that, yes. You won’t lose any stats, those are stored on servers.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Jetpack update crashed site’ is closed to new replies.