WordPress.org

Support

Support » Plugins and Hacks » [JetPack – Twitter] Twitter stuck in error

[JetPack – Twitter] Twitter stuck in error

  • Hello, on my blog, Twitter stays stuck on an error, displaying that I should wait a while and refresh the page.

    I don’t see what I could do, as there is very few configuration options. It appears that it worked very little time (I was able to add words between tweet and timestamps, for instance) but not for the last 48 hours.

    Any idea ?

Viewing 15 replies - 1 through 15 (of 28 total)
  • Your site doesn’t appear to be loading, so I would guess that perhaps your webhost is having problems that is preventing it from updating your Twitter feed.

    Thank you for answering, Beau.

    But as far as I am concerned, it seems that my site is loading. I have put back the twitter widget in the footer of my blog (on the right of the tag cloud) and it still displays an error whereas the official twitter widget (in the sidebar) displays the tweets.

    I am still getting an error when trying to load your website: http://cl.ly/1l3l2A2B2v2O163Z0v1a

    I would have to guess that somewhere between your site and the US there is a network problem that’s preventing the Twitter widget from loading your tweets from Twitter. Because the official Twitter widget loads via Javascript, it wouldn’t be affected by this problem, while ours is (since it loads from your server, directly across to Twitter).

    Is your site definitely “http://kozotujours.fr” ? I can’t even resolve that hostname using any network tools.

    Oops. I think I definitely mispelled my own site, which is, like in my username http://www.koztoujours.fr

    I am getting the same issue, but it occurs randomly.

    The particular site I’m working on with the issue is http://kellerwilliams.designbigger.com/ (s staging site). Occasionally, it’ll work perfectly fine, but more often than not, it will show the error “Error: Twitter did not respond. Please wait a few minutes and refresh this page”.

    I’ve verified the Twitter name (and other settings), and since it does seem to work properly sometimes, obviously this shouldn’t be the issue.

    Is there some sort of rate-limiting kicking in?

    I’m also seeing the same error for the past few days. Once in awhile it works, but just shows the following error most of the time:

    Error: Twitter did not respond. Please wait a few minutes and refresh this page.

    I previously used a plug-in called Twitter Tools and that worked much better.

    My blog is hosted on http://blog.hd-trailers.net/ if people are interested in seeing the error.

    I am seeing the same error on my blog, EasyBohemian.com. I’ve only ever seen my twitter comments once, every other time it’s been the error state.

    I wonder if it has anything to do with caching. I do use the HyperCache plugin on my blog.

    Unfortunately what’s probably happening is that once in a while you get an error from Twitter, and then that error gets cached by HyperCache (or some other output caching plugin), so even though a new request to Twitter might work right now, the error keeps appearing for an hour (or whatever your cache timeout is on your caching plugin).

    There’s not too much we can do about changing that unfortunately — you could try lowering your cache TTL/timeout, but that will have a net increase on your server load (although unless you have high traffic it should be very minimal).

    Hope that helps.

    One possible workaround that I’ve seen other Twitter plugins do is when you get the error, just show what the previous downloaded tweets were instead of showing an error.

    I have been getting the same message for over a month.
    Error: Twitter did not respond. Please wait a few minutes and refresh this page.

    Unfortunately although there are other useful plugins with similar widgets, when attempting to use them, Jetpack disables them saying that Jetpack has that feature already.

    The only work around this is to stop using Jetpack all together.

    I really hoped that the recent Jetpack update would fix this. But it did not.
    Salt Lake Examiner

    Currently the widget is not being used on the site since it is so random.

    I’m continuing to see the same error. If this works not even half of the time, why offer it as a feature? I was quite excited to be able to link my twitter posts to my blog but it seems like it’s not quite feasible at the moment.

    My jetpack twitter function worked perfectly until I installed a plugin for a Flickr widget. As soon as I refreshed my site, the Flickr widget appeared and Twitter showed an error message that Twitter wasn’t responding and I should refresh the window later. I deleted the Twitter widget, then un-installed jetpack and deleted the files. Then I reinstalled jetpack and added the Twitter feed back into the sidebar and now it works fine again. (I have not tried to reinstall the Flickr widget.)

    I’m getting the same across all the sites I run. I’ve not yet tried installing a vanilla site on my host and then just Jetpack to see if I get the same problem but the following WordPress.com forum thread would seem to place the problem at Twitter’s end.

    I’ve tried another couple of Twitter plugins and they all have the same problem – not getting anything from Twitter.

    Hope this helps…

    M

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[JetPack – Twitter] Twitter stuck in error’ is closed to new replies.
Skip to toolbar