Support » Plugin: Sermon Manager » Jetpack Triggers Error in sermons.php (line 560)

  • Receiving the following error in 2.16.1 (current revision with most recent fixes).

    From the stack trace it appears to be triggered by a JETPACK Sync. I haven’t traced through very much, but it’s triggering the automatic email notification by my provider saying something’s wrong… and the log file has more than a few entries like the following.
    ====
    An error of type E_ERROR was caused in line 560 of the file [REDACTED]/public_html/wp-content/plugins/sermon-manager-for-wordpress/sermons.php. Error message: Uncaught Error: Call to undefined function sm_get_screen_ids() in [REDACTED]/public_html/wp-content/plugins/sermon-manager-for-wordpress/sermons.php:560

    Stack trace:

    #0 [REDACTED]/public_html/wp-includes/class-wp-hook.php(287): SermonManager->{closure}(Object(WP_Screen))

    #1 [REDACTED]/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(”, Array)

    #2 [REDACTED]/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)

    #3 [REDACTED]/public_html/wp-admin/includes/class-wp-screen.php(421): do_action(‘current_screen’, Object(WP_Screen))

    #4 [REDACTED]/public_html/wp-admin/includes/screen.php(240): WP_Screen->set_current_screen()

    #5 [REDACTED]/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/class-sender.php(370): set_current_screen(‘sync’)

    #6 [REDACTED]/public_html/wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/class-sender.php(463): Automattic\Jetpack\Sync\Sender->get_items_to_send(Object(Automattic\Jetpack\
    =====

    Any hints or help would be appreciated.

    THanks!

Viewing 4 replies - 16 through 19 (of 19 total)
  • Plugin Author wpforchurch

    (@wpforchurch)

    Hi everyone,
    We’re sorry for the trouble.
    We are aware of the issue but unfortunately we are only able to fix this issue by installing the Sermon Manager Pro version 2.0.5 that works with WP 5.5.

    For now, please check to upgrade your WordPress core to 5.5.1 and try to reinstall JetPack 8.9.

    In the meantime, we recommend leaving JetPack deactivated to prevent issues.
    While our team is currently working for the fix.

    Thanks for bearing with us as we work through this.

    @wpforchurch The last update seems to have fixed the Jetpack errors that triggered every day. Greatly appreciate the effort as previously we had no support for this plugin.
    Good job, and thanks.

    Excellent!

    Installed 2.16.2 update. No more errors. Thanks wpforchurch support folks!

Viewing 4 replies - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.