Jetpack by WordPress.com
[resolved] Jetpack Tiled Mosaic Gallery not loading all images (41 posts)

  1. Mvd
    Posted 2 years ago #

    Ok, Jetpack support says the following:

    Ok, I went in and did a few tests. Basically, the issue is still that originally we weren't able to get the image on your slower server, so now, our system is unable to try to get the images again on the newer server. One thing you could try is to change the filenames of the images that break; that way, Photon will try to get them again and will hopefully succeed. We're working on improving our fallback mechanisms if an image isn't able to be loaded, but we're not quite there yet.

  2. Mvd
    Posted 2 years ago #

    I completely redid my site, installed wpmu with subdomains, lost the www prefix and created an english language equivalent site on a subdomain with all new images and new image names to.

    The tiled galleries don't work for this new subdomain eighter with brand new content, nor do they on the old urls without the www prefix now. The new related posts feature with "visually striking appearance" doesn't load all images. I'm realy out of clues and wish it would be possible to load images without the imposed photon cdn.

  3. Richard Archambault
    Happiness Engineer
    Plugin Contributor

    Posted 2 years ago #

    Hi Mvd, could you contact us again via email (continuing the ticket you already have with us), and include all the relevant details (like, site URLs) please?

  4. Mvd
    Posted 2 years ago #

    Hi Richard,

    I did that already before I posted the above.
    To be sure I posted on that ticket again!

    Hope to hear from you!

  5. Pepe Huerta
    Posted 2 years ago #


    Im having the same problem: some images will not load on the tiled mosaic gallery.

    It's solved by reloading the page and I'm pretty sure every single image is on the wp.com backend, since when the post got published everything worked fine:


    Even the single images in the post body are inserted as a tiled gallery to make use of the carousel feature.

    An example of the problem: https://www.dropbox.com/s/uklt9rl6241vkx0/Captura%20de%20pantalla%202014-04-15%2015.35.17.png

    The white space in the screenshot should be filled with images, as this other screenshot shows (the correct behavior of the gallery):

    Any help will be appreciated.

  6. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    @Pepe Huerta Could you please start your own thread, as per the Forum Welcome?

    Thank you!

  7. Pepe Huerta
    Posted 2 years ago #

  8. apcgallery
    Posted 2 years ago #

    Hey guys,

    I've been struggling with this for the past hour, and finally got it to work.For me the problem seems to boil down to the displaying of tiles themselves, not the images, not the cdn.

    Here's what I've been experiencing.

    I've been getting blank spaces where images are supposed to sit. In a gallery of 10 images, one is missing. When I removed the image from the gallery, the next image took its place and disappeared. I added it back, and switched the image's position in the gallery order. Got nothing. Re-create the gallery? Didn't work. Re-named the image in media editor and tried weeeweeeweee's suggestion of "rotate, save, rotate back, save" to no avail.

    I tried re-arranging the images in the gallery one more time.

    It worked.

    I feel it's also worth mentioning that Photon has never been activated on this particular WP installation.

    Here's a link to the page. I'll leave both galleries (the corrected one, and the broken one) up for the next day or so in case anyone wants to take a look.

    UPDATE: It does seem to be a display issue. This may differ from Mvd's problem, but I hope it is useful.

    I inspected the html of the "gallery-row" div, the one that contained the missing image. Its width is 671px. Inside it, there's two "gallery-group images-1" divs with widths of 436px and 236px. combined, that makes 672px.

    The second div was getting bumped down to the next row, and was hidden behind the next image in the sequence. I changed the 436px width to 435px, and the image popped back into place.

  9. skeeneyman
    Posted 2 years ago #

    I'm having the exact same problem. I've tried everything suggested so far but my images are still missing. Please help! 173carlylehouse.com/views/

  10. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    @skeeneyman Could you contact us via this contact form:


  11. Mvd
    Posted 1 year ago #


    Either Jetpack/wordpress/my hosting was fixed cause it finally works now!

    Thanks a lot Jeremy and everyone involved!!

    Topic solved (though I don't know how)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic