Support » Plugin: Jetpack by WordPress.com » Jetpack Sync cron jobs overloading server at WPEngine

  • Resolved adaptistration

    (@adaptistration)


    I have about 55 installs on an account at WPEngine and this afternoon, jetpack.full.sync.cron was overloading the server and causing all of the installs to throw 502/504 errors. All of the installs use JetPack so we had to deactivate it across all of them in order to get the server load back down.

    I noticed at https://wordpress.org/support/topic/jetpack-sync-killing-the-db/ this appears to be a known issue but I don’t see anything about it in any of the subsequent changelogs. Do you know if this has been addressed and if not, is there a temp fix I can put in place so as to be able to reactivate JetPack across my installs?

    Some of the higher traffic installs include:

    adaptistration.com
    morikami.org
    townhallseattle.org
    fourarts.org
    creationtech.com
    insidethearts.com

    Jetpack has been deactivated across all of those.

    Many thanks!

Viewing 12 replies - 16 through 27 (of 27 total)
  • Yes, it does seem like that’s the same solution albeit it we found it more efficient to implement across multiple WPE installs using a MU-plugin.

    Is the option in the impending 4.5 release the same thing or something different?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Is the option in the impending 4.5 release the same thing or something different?

    It is a bit different. You can find out more about the relevant changes here:
    https://github.com/Automattic/jetpack/pull/5879
    https://github.com/Automattic/jetpack/pull/5996

    If I’m following everything correctly this new option modifies the cron to run at a max of 30 seconds, otherwise, the original structure remains unchanged. Correct?

    If so, then I would think that the system I have in place at my WPE server via Brandon’s assistance would still produce lower server load, no?

    Drew

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Our changes do indeed limit Cron to make sure it doesn’t get stuck, and change it so it runs every 10 minutes.

    I believe the filter will consequently remain useful in the case of WP Engine, as it bypasses Cron altogether.

    Gotcha, so leaving that filter in place when the 4.5 update rolls out means there’s nothing to really change on my end since it is still bypassing the crons.

    If that’s not correct let me know, otherwise I think I’m clear.

    i have last jetpack installed, last WP.
    I have added around: 38websites in wordpress-jetpack, it causes high load to my server….
    When i log in to wordpress.com and go to dashboard in “mytop” i have a lot of connections to my database thus causing a high load.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @paunescumihai That may indeed happen if all sites are hosted on the same server; when you access WordPress.com, the central interface runs API queries against each one of the sites to gather information and display it in the interface.

    To solve this issue, we’ve implemented a new synchronization system, discussed a bit above and described here. We started synchronizing more data about each site, and we’re now working on using that data in the WordPress.com interface instead of querying each one of your sites every single time.

    We’re still working on this, but if you’d like you could help us test it by going to the WordPress.com test interface:
    https://horizon.wordpress.com/settings/general

    There you’ll be able to select one of your sites, and then check the “Use synchronized data to boost performance” box at the bottom of the page. You can do that for a few of your sites, and you should immediately notice that the WordPress.com interface will make a lot less calls to your sites to gather information.

    Once we’re happy with the synchronized data displayed everywhere in the interface, we’ll enable this for every WordPress.com user.

    I hope this clarifies things a bit!

    i cannot do that for 40sites, cause it takes to long and the stress on my server is to high…
    can you please do it via backend or somethin….

    if i try to do it….

    i have this error:
    There was an error retrieving your site settings.
    Make sure your Jetpack is up to date

    jetpack is connected and up to date.
    also i tried to reinstall and reconnect jetpack on those specific sites and i have same err..

    • This reply was modified 2 years, 8 months ago by  paunescumihai.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    can you please do it via backend or somethin….

    I’m afraid that’s not possible right now. I can only recommend that you wait until the feature is released for everyone.

    i have this error:
    There was an error retrieving your site settings.

    That’s most likely because your server either doesn’t respond, or rate-limits the requests since there are so many requests hitting your server at once.

    I added all sites like you said. (everything is better now)
    But for new ones i have the error:
    Jetpack 3.3-dev is required to manage Settings
    and after that
    There was an error retrieving your site settings.
    Make sure your Jetpack is up to date

    i use last wp last jetpack.

    My server does not rate limit anything…

    When i go to wordpress.com
    i get this error:
    Jetpack 3.3 is required to take full advantage of plugin management in corpul-perfect.ro.
    Update now

    But i have the version Versiunea 4.6 | De Automattic | Vezi detaliile
    installed.
    What now?
    I tried reinstalling and have the same error…

    it worked after:
    sync; echo 3 > /proc/sys/vm/drop_caches;sync; echo 2 > /proc/sys/vm/drop_caches;sync; echo 1 > /proc/sys/vm/drop_caches
    and nginx+httpd restart, and a few refreshes on

    https://horizon.wordpress.com/settings/general/domain.tld

    • This reply was modified 2 years, 8 months ago by  paunescumihai.
    • This reply was modified 2 years, 8 months ago by  paunescumihai.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I added all sites like you said. (everything is better now)

    Excellent, I’m glad to hear it!

    It looks like you got everything else sorted out! Let me know if you have more questions!

    • This reply was modified 2 years, 8 months ago by  Jeremy Herve.

    Jetpack is always a problem and Akismet leaves a cron job even after you uninstall and delete it:

    akismet_scheduled_delete

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Jetpack Sync cron jobs overloading server at WPEngine’ is closed to new replies.