WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Jetpack subscriptions send both excerpt and part of the original post.

[Resolved] Jetpack subscriptions send both excerpt and part of the original post.

  • Hi,

    I just noticed that subscribers get an email with both the excerpt and a part of the post. The first few lines of the post are above the entire article, as you can see in this image.

    The original post is here.

    I don’t want the extra lines above the article, as they are now. Especially since shortcodes will turn up to in there.

    I’d like the shortcodes to actually show what they’re supposed to show, but there’s already a topic about that so I won’t start that in my own topic.

    Hopefully my problem can be solved easily.

    https://wordpress.org/plugins/jetpack/

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m thinking if this can’t be solved, I’ll just use a newsletter like Mailchimp and send weekly/biweekly newsletters instead. That might come in handy as well, especially since I’ll be able to use my own layout for that.

    But in the meantime this should be solved anyway. I don’t think it’s supposed to be sent like this.

    Plugin Contributor csonnek

    @csonnek

    Hi there!

    Sorry for the delay in responding – since you replied to your thread, it wasn’t evident that you hadn’t been answered. Apologies!

    I’d like to be able to test the emails that you receive – can you temporarily enable your subscriptions widget so I can sign up with a test email address? This is the first report of this issue that we’ve seen, so I’d like to rule out any server/site configuration/email client problems first.

    Let me know if you have any questions. Otherwise, I’ll wait to hear back from you!

    Hey Carolyn,

    Sure, I’ll setup the widget for you. Can you let me know when you’ve subscribed so that I can exclude the widget again?

    Thanks!

    Also, I’ve got another problem still open, about the double sharing module. I don’t know if you guys thought that was resolved? Cause it really isn’t 🙁

    Plugin Contributor csonnek

    @csonnek

    I have subscribed to your blog.

    Regarding your other issue – since others had replied to your thread, it escaped our notice. We don’t have any special notifications to let us know if things are unanswered, so it wasn’t intentional. I’ll take a closer look at that one shortly.

    Hey Carolyn,

    Thanks so much for your help! I already had the idea the other topic might have been overlooked for exactly that reason 🙂 That’s okay. I’m glad you’re looking into it though!

    I’ll post a new post on my blog. Let’s see what you get in your mail. Perhaps it’s just some weird setting in my profile, or setup or something…..

    Plugin Contributor csonnek

    @csonnek

    Just received your latest email post notification and it’s displaying properly for me (I use Google Apps for my email): http://d.pr/i/1i0x

    What that tells me it might be an issue with your email client. What email client do you use – it’s possible there’s an option to “preview” the links the email – whether it be a link to a video, a link to a website, or a link to a blog post (in your case). In your example email, it looks like a lot of the graphical elements are not loading or are being blocked as well.

    Let me know what email client you’re using (and what version if applicable), and I’ll dig into this further.

    Hmmm… Let me check that. I’ve got Outlook for this particular sub. I can sub with a gmail account as well.

    I have set Outlook not to give a preview but only to show the mail when it’s properly opened (to avoid virusses and such as much as possible), but perhaps there’s something I’ve done wrong?

    BINGO. Okay… sorry for the capitals 😆
    Anyway, Gmail processes the mail properly. So apparently it’s something in Outlook?

    Ah, and I’m using Outlook 2007 (from the office pack) (12.0.6691.5000) with SP3 MSO (12.0.6683.5000).

    Thanks for all the help!

    ETA: Oh, just opened the mail in the browser from Outlook and before it could open, Outlook said something about the browser maybe not having the same security settings and thus not blocking everythign Outlook blocks. I don’t know if that helps?

    And since Outlook is nagging about security: I’ve got GData installed, but the wordpress.com domain is whitelisted in Outlook.

    I’ve gone over all options in Outlook, but I don’t see any securitything that might block things, but perhaps I don’t know enough about it 🙂

    Thanks for all the help!

    Plugin Contributor csonnek

    @csonnek

    Yeah, I’m not super-familiar with that plugin for Outlook – so it’s hard to say. I would try viewing the emails without the GData plugin enabled – the settings there seem to be overly aggressive. I’ve found Microsoft’s Security Essentials to be pretty robust for overall PC security and it does check all Outlook emails for any nefarious things.

    Marking as resolved as it appears to be Outlook related.

    Thanks for all the help, Carolyn! It’s a good thing it’s Outlook related instead of hte plugin 🙂

    Plugin Contributor csonnek

    @csonnek

    You’re welcome! Glad we were able to sort it out. 🙂

    Yay, one problem solved. Two more to tackle, one here and one with pods. Josh Pollock is a wonderful help with that one!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Jetpack subscriptions send both excerpt and part of the original post.’ is closed to new replies.
Skip to toolbar