Jetpack by WordPress.com
[resolved] Jetpack subscription - when new post, should send just snippet not entire post (4 posts)

  1. carol.preibis
    Posted 3 years ago #

    When there is a new post, the Jetpack subscription service sends subscribers an email with the entire post. It would be far better to send just a snippet. The subscriber needs an incentive to actually go to the blog!


  2. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    There are 2 ways to send an excerpt of your post to your subscribers.

    1. In Settings > Reading, you can set your feed settings to "Summary". Once you have saved your changes, Jetpack will only send an excerpt of your post to your subscribers.
    2. You can split the content of each one of your blog posts in 2 parts thanks to the More tag:

      Everything that is above the More tag will appear on your home page and in the subscription emails, followed by a link inviting users to click to continue reading; everything that is below that tag will only appear on the post's page.

      You can read more about it here:

  3. infrontweb
    Posted 2 years ago #

    We are using some shortcodes on our post and the subscriber receives the shortcode copy which is not legible via email. We have Settings > Reading > feed settings set to "Summary".

    We have a custom excerpt written but the email doesn't seem to be using that? Can you help?

  4. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 2 years ago #

    @infrontweb Could you please start your own thread, as per the Forum Welcome?

    it might also be useful if you could let me know your site URL so I can have a closer look. If you want it to remain private, you can also contact us via this contact form:

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic