WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Jetpack Stats not working

[Resolved] Jetpack Stats not working

  • foodiebuddha

    @foodiebuddha

    I just upgraded to the latest jetpack. Since I upgraded, my stats option is gone. If I go to the jetpack dashboard, I see the configuration and can save changes, but that’s it. The stats menu is gone, the stats box on the toolbar is gone, and I’m stumped. The url DOMAIN/wp-admin/admin.php?page=stats now gives me a “You do not have sufficient permissions to access this page.” message.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 41 total)
  • Lee

    @diondeville

    You need to disable and re-enable the plugin then reconnect with WordPress. However, though the stats menu will again be visible, you might still suffer the permissions issue when trying to view stats. I know this because I’m suffering the same problem since today’s update.

    If you have strong rewrite rules in your htaccess file you might need to whitelist the WordPress servers to permit the plugin to connect with wordpress.com for registration. I’ll give you the details if you need them.

    foodiebuddha

    @foodiebuddha

    thanks, I had already tried disabling and that did not help.

    I would love some details on the whitelisting you mentioned! Thanks for the help!

    Lee

    @diondeville

    I think we’ll need an update before we can again view the stats page. The final bar in the little graph in my admin bar still seems to be growing so the plugin’s probably working even though I can’t view the admin page.

    Place these whitelist rules above your .htaccess rewrites to whitelist the wordpress.com servers:

    RewriteCond %{REMOTE_ADDR} !74\.200\.244\.
    RewriteCond %{REMOTE_ADDR} !76\.74\.248\.
    RewriteCond %{REMOTE_ADDR} !66\.135\.48\.
    RewriteCond %{REMOTE_ADDR} !69\.170\.134\.

    There might be other IP addresses too. If there are, I’d love to know.

    studio544

    @studio544

    I have had the same issue since yesterday with some of my sites after installing the latest Jetpack upgrade. I seem to be getting partial information on the site stats page but the bars and graphs are gone. It appears unable to connect properly. Since I manage multiple sites, I will NOT be upgrading this again until they have the issue resolved as I have no idea what you are referencing with the .htaccess rewrites. Where would I this within WordPress? Thanks. Hopefully enough people will complain about the issue to force them to fix the issue ASAP.

    rodtrent

    @rodtrent

    Same issue here, but this morning (after deactivating and activating), it will not connect to WordPress.com at all to enable the components.

    Lee

    @diondeville

    The latest version released overnight has fixed the issue for me. The new version is 1.2.1.

    For those with connection/authentication issue, either whitelist the WordPress servers in your .htaccess file rewrite/firewall directives using the rules in my above post OR temporarily remove any directives in your .htaccess file that are not essential for WordPress to function e.g keep “DirectoryIndex index.php” at the top and keep “## BEGIN WORDPRESS”, “## END WORDPRESS” and the bits between the WordPress block then authenticate then replace the bits removed from your .htaccess file (put them back where you found them).

    foodiebuddha

    @foodiebuddha

    Thanks for all the help everyone. The latest update did fix the problem.

    Lee

    @diondeville

    You’re welcome and I’m glad it’s fixed for you too.

    studio544

    @studio544

    It’s still not working for me. I installed the latest update of 1.2.1 but the stats are not working. Do I still need to screw around with the .htaccess file besides the update or should I disable/remove Jetpack and reinstall it? I thought the update would have fixed the issue on its own. Thanks.

    @studio544: could you provide more details on exactly what is going wrong for you? If you could also follow the guidelines here and provide some of the information requested, it would be very helpful.

    Thanks,

    Tim

    studio544

    @studio544

    Sorry, I just got back. I am using IE8 but also tested it in Firefox with same results. The site is hosted by Host Monster. Worpress version 3.2.1. Everything was working fine for me until I installed the Jetpack update as reported earlier. What’s happening when I go to view the stats is that the WordPress animated “loading” logo spins and spins but never loads the usual bar graphs. I can see the other stats below like Referrers, Top Posts, Search Engine Terms, Clicks but it’s all jumbled up like the CSS is no longer connected to it. Is everyone else still seeing the bar graphs?

    SJDankoSF

    @sjdankosf

    I’m having pretty much the same problem. The WordPress animated “loading” logo spins and spins but the bar graphs never load. I can see the usual stats below.

    jschwartz63

    @jschwartz63

    Site stats for 1.2.1 still not working. Using diffrent themes (Standard Theme) and (EVolve Theme) on two different self-hosting acounts at Bluehost. When 1.2 came out and did not work I rolled back to 1.1.3 wothout any problems. Dissapointing to say the least. Even with 1.2.1 the stats page shows but the bar chart does not appear. Only the revolving ‘W’ shows.

    Tonglil

    @tonglil

    I also have an issue with Jetpack.
    For some reason the stats say: We were unable to get your stats just now. Please try again.
    It has been around for over 2 weeks now.

    I am new to WordPress.org Forums so I apologize if I’m being redundant or asking an obvious question. Like everyone here, I have updated the latest Jetpack and get this error message when I click on “blog subscriptions” on the site states page: “We were unable to get your stats just now. Please try again.” Seems like the last post on this forum was a week ago. Is everyone still waiting for a resolution? Thanks so much!

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘[Resolved] Jetpack Stats not working’ is closed to new replies.
Skip to toolbar