Support » Fixing WordPress » [Jetpack] Stas page shows code

  • Hello guys, I run a self-hosted WP installation with JetPack by installed. Recently I had a security breach (similar to: I managed to clean the site, but from that point on Site Stats doesn’t display any graphs.

    The graph works fine on the Dashboard, the problem comes up when visiting the dedicated site stats page at /wp-admin/admin.php?page=stats. Instead of showing any graphs it just displays the javascript as code (text) instead. Example:

    +ADw-script type+AD0AIg-text/javascript+ACIAPg /+ACo +ADwAIQBb-CDATA+AFs +ACo-/ jQuery.ajaxSetup(+AHs-cache:true+AH0)+ADs jQuery( function(+ACQ) +AHs +ACQ( '+ACM-chartswitch li a' ).click( function() +AHs +ACQ( '+ACM-stat-chart-legend' ).html( '' )+ADs +ACQ( '+ACM-stat-chart' ).html( '+ADw-img src+AD0AIg- style+AD0AIg-margin-top: 70px+ADsAIg /+AD4' )+ADs if ( 'stat-human' +ACEAPQ ) +ACQ( '+ACM-stat-chart' ).load( 'admin.php?page=stats&noheader&chart=flot-stats-data', +AHsAIg-page+ACI:+ACI-stats+ACI,+ACI-blog+ACI:31003777,+ACI-num+ACI:30, 5 )+AH0 )+ADs +ACQ( '+ACM-chartswitch a' ).removeClass( 'active' )+ADs +ACQ( '+ACM' +ACs ).addClass( 'active' )+ADs this.blur()+ADs return false+ADs +AH0)+ADs // access toggle +ACQ('+ACM-accesscontrol legend').each(function (i) +AHs +ACQ(this).click(function () +AHs +ACQ(this).parent().toggleClass('peekaboo').next().toggle()+ADs +AH0)+ADs +AH0)+ADs +AH0)+ADs /+ACo +AF0AXQA+ +ACo-/ +ADw-/script+AD4 +ADw-script type+AD0AIg-text/javascript+ACIAPg

    and it goes on with lots more code…

    I tried deleting/reinstalling, etc but it hadn’t been fixed.
    Any ideas?

Viewing 1 replies (of 1 total)
  • I had exactly the same experience, after my website has been hacked my web host restored my website into new installation, however I did restore for my old database, my theme was missing and most of my blog images were deleted. After restoring the blog, activating and configuring some security plugins I noticed that I receive exactly the same message when I check Jetpack states, the image is still shown in the banner.

    Also when editing old posts or adding new posts and hit the publish button, the published article will not be complete text and would stop at special characters not only in the post but anywhere at my blog, even if I want to add a code or anything it don’t accept some charter and refuse to save as if it didn’t type them in.

    Could any one please help, I would really appreciate it.

Viewing 1 replies (of 1 total)
  • The topic ‘[Jetpack] Stas page shows code’ is closed to new replies.