Support » Plugin: Jetpack by WordPress.com » Jetpack slideshow not advancing

  • Resolved geomouchet

    (@geomouchet)


    I disabled the slideshow plugin I was using and replaced it with Jetpack slider. I set the slideshow to automatically advance every three seconds, but only the first image displays. The forward (>) link does nothing, but I can manually advanced the slideshow by clicking on the control at the bottom, where there is a dot for each image.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    It’s working properly for me under Firefox 72.0.2.

    First, please make sure that your browser is up to date: https://browsehappy.com/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    I tried with Firefox 72.0.2 and Chrome 79.0.3945.130, both up-to-date versions. Clearing cache and cookies and turning off all browser extensions didn’t help. Since it was working for you I tried on my laptop (Win 10, same as my desktop that has the problem). It works fine on my laptop and also on my Android phone. Now I’m really mystified. I might not worry about it if it’s only my computer, but what if it’s, say, 25% of all Win 10 computers?

    Plugin Support KokkieH

    (@kokkieh)

    On your PC, open Windows Settings, and go to Display Settings. Under “Simplify and personalize Windows”, is the Show Animation toggle on or off? If it’s off, does switching it to On help?

    If so, it’s the same issue as reported in https://wordpress.org/support/topic/slideshow-block-autoplay/, and you can see a workaround to prevent this from happening on Win 10 computers with that setting active in that thread.

    I’ve also reported this to our developers in https://github.com/Automattic/jetpack/issues/14523, but this could be an intentional decision to have the slider respect that setting, in which case it might not be changed from our end.

    Plugin Support KokkieH

    (@kokkieh)

    Okay, a developer has confirmed that this is expected behaviour with that Windows setting, and it’s not something we’ll be changing.

    If you want to force the slider to work regardless of someone’s Windows settings, the workaround devised by the user in the other thread (use at own risk 🙂 ) is the only option.

    Apparently that’s the issue. Show Windows Animation was off on the PC where the slideshow didn’t work. I disagree with the idea that reduced animation means all slideshows should fail. If the slideshow works with some settings and fails with others, it’s confusing and I would consider it to be unreliable behavior. It’s even worse that the non-functioning play/forward/back buttons are displayed. I suppose there are cases where a slideshow is just fluff and other cases where it’s a critical part of a website’s design. Perhaps it would be better if Jetpack allowed the website designer to choose if the animation will work with that setting or not. I don’t see the suggested workaround as a viable solution, as it would likely be undone with future Jetpack updates. At this point I guess I’ll just use a different slideshow plugin. I suspect that none of the other ones have this issue.

    Plugin Support KokkieH

    (@kokkieh)

    I disagree with the idea that reduced animation means all slideshows should fail. If the slideshow works with some settings and fails with others, it’s confusing and I would consider it to be unreliable behavior.

    It does not mean all slideshows should fail, no. The Jetpack slideshow doesn’t work with that setting active, because the plugin chooses to respect that setting, and if MacOS, Linux, Android or iOS were to introduce similar settings, Jetpack would likely respect it there as well. Other plugins might choose not to respect that setting, but that’s a choice the developers of those plugins have to make.

    It’s even worse that the non-functioning play/forward/back buttons are displayed.

    Those buttons worked fine for me, both on your site and on another site where I tested this on Win 10 with that setting active. So the buttons not working for you is unrelated to this setting, and likely something else specific to your computer or browser.

    Perhaps it would be better if Jetpack allowed the website designer to choose if the animation will work with that setting or not.

    As per the reply in the GitHub issue where I reported this, it doesn’t look like that’s going to happen. So if this is a deal-breaker, it looks like you’ll have to use a different slideshow plugin, yes.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.