Support » Plugin: Jetpack by » JetPack Slideshow Gallery Issue

  • Resolved Jose Delgado


    We are trying to use WP Jetpack Galleries.
    Some of its gallery types work fine, like the Thumbnail Grid.
    Unfortunately our client prefers the Slideshow better, but we can’t make it work with our Theme (WP Devine Theme), though it does work with the official WP Twenty Twelve Theme for instance.

    You can see our testing page here:
    Scroll down to the Tabs area. 1st Tab uses Flex Slides (a plugin from our theme), 2nd Tab uses our theme shortcode gallery option, 3rd uses JetPack Thumbs Grid and 4th Tab, named “Mamparas”, uses JetPack Slideshow.

    Any idea why the JetPack Slideshow doesn’t work?
    Thanks in advance,


Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    I had a look at your site, and your theme or one of your plugins seems to be loading an old version of jQuery instead of using the version that comes bundled with WordPress.

    It can create multiple conflicts with WordPress and with other plugins like Jetpack. You can read more about it here:

    Try switching to a different theme for a few minutes, and check if that solves the issue; if it does, you’ll want to look for the function loading jQuery in your theme’s header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:

    If the issue is not related to your theme, please try to disable all your plugins, one at a time, until you find the one that causes the conflict. You can then enqueue jQuery using the method I linked to above.

    If you do not feel comfortable editing PHP files, you can also contact the theme or plugin author and ask them to solve the issue.

    Hi Jeremy,
    I expected the same issue: I used to have a slideshow in the following post and after updating the Jetpack plugin, it turned into in a tiled gallery. I desactivated all plugins, disconnected and reconnected Jetpack, but you don’t have the “slideshow” option anymore when creating a new gallery in posts…
    Any clue about what’s happening?
    Thank you in advance!

    Hi asdevargas,
    Jeremy was right in my case.
    When I set a simpler theme like twenty twelve the Slideshow works fine (it loads the latest JQuery).
    I verified that my theme loads an older JQuery so that’s the source of my issue in my opinion.

    My problem now is how to modify my theme (WP Devine) to load the correct JQuery file.


    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @asdevargas Jetpack doesn’t seem to be properly connected to your account at the moment. Could you go to the Jetpack menu in your dashboard, and disconnect from thanks to the button in the top right corner? Once you reconnect, make sure that the shortcode module is active, and the slideshow gallery type should appear.

    If it doesn’t, can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the “Select All” button.
    5) Send us the test results via this contact form:


    Yesssss!!! It works, thank you!

    Would you know how I can force current theme (WP Devine) to load the correct JQuery file?
    I’ve tried contacting the theme creator but got no answer so far.

    What I’m trying to find out is how that file gets loaded on a theme and how that can be modified.

    I’d appreciate any feedback.


    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    I’m using Lazy load for videos plugin in my web.
    This plugin has an incompatibility with the shortcode module, so I have to deactivate it.

    Solved: The plugin isn’t working with Jetpack…

    “Jetpack” by offers some useful extensions. Only one of them makes Lazy Load for Videos break – the “Shortcode Embeds” extension. So simply disable the extension. (In order to see a “Deactivate” button for “Shortcode Embeds” on the Jetpack’s extension overview, you must click on “Learn More”.)

    But now I can’t use slideshow jetpack gallery as I’ve read to asdevargas.

    Is there any idea to compatibilize slideshow jetpack gallery without deactivating shortcode jetpack module?

    I use athaualpa theme.

    Thank you in advance.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @farsite281 Could you please start your own thread, as per the Forum Welcome?

    Thank you!

    Ok, sorry!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘JetPack Slideshow Gallery Issue’ is closed to new replies.