Support » Plugin: Jetpack by » Jetpack: site_inaccessible

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic 🚀

    Do you use a self-signed SSL certificate on your domain? If so, you won’t be able to use Jetpack without making a small addition to your site’s wp-config.php file:

    define( 'JETPACK_CLIENT__HTTPS', 'NEVER' );

    If that doesn’t help, can you please use Jetpack’s Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button.


    Yesterday, I sent my report for your support.

    But, I found out it might be a real reason a short time ago.

    At, my main site has gone. I don’t know why such a thing happened. My main site URI is But it disappeared and my old test site name showed up. Maybe this is the real reason why I cannot use Jetpack.

    When I registered my domain to, it was easy. However, this time I cannot find the link for it. Though I ask a wrong person, can you tell me how I can fix it?


    Plugin Contributor Richard Archambault


    Hi! I had a look, and you’re right, I see a test site and a few other sites listed for your account, but not your root site. I do not know why it would be disconnected from but if you try to connect it, it should work. All you need to do is go to the dashboard for your root site, go to the Jetpack page, and click the button that says “Connect to”

    For the record, your site should get back it’s old id that we have in our system, 30188596. Once you’ve reconnected, I can check that for you.

    I also saw that you sent in a support request by email. We can continue this conversation here or by email, whichever you prefer. For now, I’ll leave your emailed request closed but you can reply to it there if you prefer. 🙂

    Hi, thanks for your reply!

    Basically, I use here except I need to write about my private information.

    By the way,

    > All you need to do is go to ~~ “Connect to”

    Unfortunately, it is NO. Actually, when I logged in my root site at the first time after the renewal, I found the button “Connect to”. I was wondering why I need connecting to about my root site again, I clicked the button, but I got the error message above I wrote and the button that says “Connect to” still stayed there.

    After reading your reply, I tried it again and got the same result. And I tried to connect Stats by the old ID you gave from the web browser address bar, then I had the message below.

    You are not a member of this site.

    If you have just installed the Stats plugin, this error probably appeared because the API key entered in the plugin belongs to a different user account.

    The owner of the API key must visit this site’s stats page to grant access.

    You are logged into as o6asan. To switch accounts, log out.

    My root site is the parent of a WordPress Network. The old test site does not exist on the Network anymore, so, a person reaches to my root site if the person accesses the old test site because of WordPress Network rewrite rule. This behaviors might be the reason I cannot resister my root site as a new site on

    If I recreate a new site which has the same URI of the old test site, does it make an effect or give more troubles? I have not tried it yet because I’m not sure about it.

    Or can they fix their databases for me if I ask it to

    I need assistance. Thanks.

    As a new test site having the old URI did not work well, I asked Support to delete all information of the old test site.
    Now, I’m waiting for an answer.

    Plugin Contributor Richard Archambault



    I looked through our tickets and I couldn’t find your latest request. Did you send it from the same email address?

    In any case, I’ll continue this thread by email since I can better keep track of your particular issue there, so I’ll mark this thread as resolved. Expect an email from me shortly. 🙂

    Oh sorry, Richard!
    I sent my request to Japanese Forum. So, you couldn’t find it.

    I had an answer from Japanese Support and I’m waiting for another answer. Please be patient. If I have the answer, I’ll report about it here.

    By the way, I checked SITE_URL up and I confirmed it was

    You say on your email:

    that may be the source of the problem that you are having.

    But I don’t think so. Because when I tested all sites on my Network with, they gave me the same result and the sites except my Root Site have no problem.

    I have fixed the issue.

    I wrote;

    that may be the source of the problem that you are having.

    But I don’t think so.

    But, after posting, I doubted define( 'FORCE_SSL_ADMIN', true ); might have an affect on this trouble if Richard, who has wide experience than me, thought the trouble was related with SSL. I confirmed my SITE_URL was though.

    I commented the line define( 'FORCE_SSL_ADMIN', true ); out, and tried to connect to Wow, Authorize Page showed up and I finally reached Authorization. So, I got that the authorization might fail with define( 'FORCE_SSL_ADMIN', true ); on some conditions.

    After the connection to, I rolled define( 'FORCE_SSL_ADMIN', true ); back. It is O.K. after the Authorization even if define( 'FORCE_SSL_ADMIN', true ); is uncommented.

    I have never resolved in my mind why this suddenly happened. But, the issue solved.

    Thanks for your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Jetpack: site_inaccessible’ is closed to new replies.