Support » Plugin: Jetpack by » Jetpack site_id_ invalid. Site already connected to wordpress

  • Resolved kmkillebrew


    A couple of weeks ago I moved from to self-hosting through Blue Host. I used the jetpack to move everything over with success. Everything was working fine until a week ago when I contacted WordPress support to ask them if they could transfer my subscribers over. WP support told me that my jetpack connection was displaying a temporary address on their end and gave me the following instructions:

    “1. Go to the Jetpack page in your site’s dashboard
    2. Click the “Connected to” button in order to disconnet
    3. Make sure that the domain name is displayed in your browser address bar and in the Site URL field under General -> Settings
    4. Go back to the Jetpack page in your dashboard and click “Connect to”

    Please let me know when you’ve updated your Site URL and reconnected Jetpack, and I can transfer your subscribers for you.”

    I followed the instructions but when I tried re-connecting the jetpack, I got the following error:

    Your site is already connected to wordpress.

    But it’s not.

    After clicking on it several more times I then got a different error message:

    The jetpack server was unable to communicate with your site [IXR – 32300: transport error: http_request_failed
    Couldn’t resolve host ‘’]

    I continued to get these two different messages at different times of trying to connect the jetpack. Within the past couple of days I’ve only been getting the first one now.

    I’ve spoken with at least half a dozen Blue Host reps for several hours over this issue. They have tried everything. Disabled all plugins, reinstalled jetpack, verified that my xlmrpc.php was present, etc, etc. Nothing has worked.

    It was working fine until I followed the instructions to disconnect and then reconnect Jetpack.

    The WordPress Support happiness engineer that I was communicating with finally responded with: The error you’re getting sometimes occurs when the domain was previously in use on I’ve asked our Jetpack team to take a look. I’ll be in touch as soon as I have any further information…Usually takes 1-2 business days.”

    It’s been more than two business days and still no response. I had submitted a ticket to Jetpack Support 4 days ago as well, independent of my communication with WordPress support, and have not received a response from them either.

    PLEASE, I need help!

    I’ve looked at numerous forums on this topic, hoping to find a solution. This is apparently a very common problem, but the common theme seems to be: Problem…no solution.

    Is there anyone out there who can help me with this? This has gone on for too long now with now response from Support.

    P.S. I am a complete novice at this and don’t know the first thing about making any css edits myself.

    This is for website

    I’m using the latest version of WordPress and Jetpack. I’m using the Eleven Twelve them.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor Jeremy Herve


    Jetpack Mechanic

    I had a look at your site, and Jetpack seems to be connected to at the moment. Have you managed to solve the issue by yourself?

    P.S.: I seem to remember these beautiful food pictures; I think I replied to an email from you as well. Check your inbox! 🙂

    It’s working now as of 10 minutes before your reply. I received an email from Support saying they made an update and try connecting again. This time it finally worked! Not sure what the problem or solution ended up being, but at least things are finally back to working again. Thank you!

    And thanks for the compliment, Jeremy 🙂

    Actually, one more small thing if you’re able to address it: My number of subscribers now show as zero since the update (my site stats are also all at zero)even though I have quite a few. Is that something you can reset? I had lost all of my subscribers when moving from to self-hosted as well – can you move all of those? I had several email subscribers as well as rss feed subscribers, but everything showed as zero when I moved.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic

    I have made some changes to your account, and transferred your subscribers from your blog. The transfer should be complete in a couple of hours.

    Could you try to go to the Jetpack menu, and disconnect / reconnect to once more? That should solve all your problems.

    Yes! My email subscribers have all been moved and show up in my stats. THANK YOU!! The rss feed subscribers don’t show as having been transferred yet. I’ll wait the couple of hours and see what happens…

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic

    The rss feed subscribers don’t show as having been transferred yet

    I’m not sure what you mean by RSS subscribers? Since you used your own domain on, your RSS feed was the following:

    When you moved to a self-hosted version of WordPress, your RSS feed address didn’t change so your RSS feed subscribers should still receive updates from your latest posts.

    I had around 104 RSS feed subscribers before transferring that I had accrued in the two weeks my site was up at But when I moved to self-hosting the feed statistics showed as “0”. I’ve since acquired 88 more this past week, so shouldn’t it show 192 now?

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic

    I am afraid I do not have any control over your RSS subscriber counts; they are not handled by Jetpack.

    Which tool do you use to monitor your RSS subscribers?

    Just the RSS widget that comes standard, I believe. Then I track the numbers with the feed statistics plugin. At I didn’t have to use that – my built in site stats automatically included those figures. Also, the jetpack follow blog widget that comes standard has the option of showing those numbers on my website. At those numbers included both email and rss feed subscribers. Now they only show email subscribers.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic

    Sorry for the confusion. Let me try to sum up the different solutions available on and on your new self-hosted site.

    The Jetpack Subscriptions widget you use on your site is similar to the Follow widget you used on your site: it allows readers to sign up and receive email notifications about your latest posts.

    It also allows you to display a count of your subscribers:

    • On, it will display the total of your followers, email subscribers, and all your friends on Facebook and followers on Twitter if you have connected your blog to one of these Social Media sites.
    • On your new self-hosted blog, it still displays the total of your followers and email subscribers, but does not count your Facebook and Twitter friends. That might explain the discrepancy.

    None of these 2 widgets actually include the people who follow you via RSS; they are not counted among your Followers, and do not appear in your Site Stats. You’d have to use another plugin to track them.

    Does this help a bit?

    Yes, I understand now. Thank you for clarifying this for me.
    And thank you so much for solving my jetpack connection problem!

    Jeremy, I’m having the EXACT same problem with Jetpack. (Everything was working and I received a message from technical support telling me to do the same thing and now I’m getting the same invalid id message) Is it possible for you to take a look? It would be hugely appreciated.


    Jeremy, one last question: I noticed my W3 Cache plugin was deactivated in the process of updating the Jetpack so that it would connect again. Can I safely activate that or is it going to cause problems for my Jetpack?

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic


    Can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the “Select All” button.
    5) Send me the results via this contact form:

    Thank you!


    You can reactivate W3 Total Cache!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Jetpack site_id_ invalid. Site already connected to wordpress’ is closed to new replies.