Support » Plugin: Sharing buttons shortcode for Jetpack » jetpack sharing buttons not showing on blog

  • Resolved TZAL

    (@tzemaitis)


    The JPshare buttons show OK on other selected pages & all posts in the sidebar but not on the blog page (showing posts).

    Using JP visability to set where the buttons show & this is set to:

    1. some seleced pages
    2. Blog static page
    3. All posts

    Settings>sharing has pages & posts ticked.

    Any advice to getting the sharing buttons to show on the blog/postspage would be appreciated.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    May I ask where you added the shortcode itself, and where you’d like the buttons to appear? Do you want to display buttons below the content of each post on that blog page? What are your sharing settings for that specific “Blog” page in the editor?

    TZAL

    (@tzemaitis)

    Hi Jeremy

    1. Shortcode is Appearance > Widgets > Sidebar Right > Custom HTML widget

    2. I’d like the buttons to appear on the righthand sidebar on https://www.zemaitis-uk.com/blog/ below the Search widget( where it is placed in widgets) – just like it does on all posts e.g. https://www.zemaitis-uk.com/how-to-re-tender-for-an-existing-contract/

    3. No, I do you not want to display buttons below the content of each post on that blog page

    4. Visibility settings of widget (in 1) are:
    show if:
    Page is Post
    Page is Blog (this is the static page that the buttons aren’t displaying on)
    Page is Free Resources including Children)

    Hope that explains it.

    Tony

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the extra details.

    Could you go to Settings > Sharing and try checking the “Front Page, Archive Pages, and Search Results” option?

    Let me know how that goes.

    TZAL

    (@tzemaitis)

    That option wasn’t ticked before.

    Now ticked but it made no difference.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    If you remove the shortcode altogether, do you see the sharing buttons at the bottom of the Blog page?

    If not, then the shortcode won’t work either.

    Do you see the sharing buttons on other pages, or on your home page when that option is checked under Settings > Sharing?

    TZAL

    (@tzemaitis)

    If I remove the shortcode altogether, I do not see the sharing buttons at the bottom of the Blog page. BUT they were never showing at the bottom of this page and they do show at the bottom of each post excerpt.

    Sharing buttons (bottom & sidebar) all work as expected on every other page.

    I have just noticed on https://www.zemaitis-uk.com/blog/ > Edit Page – no options are showing at the top right e.g. Settings, Yoast, Jetpack. So, I presume that I couldn’t turn on sharing buttons at the bottom of the page anyway?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Yes you’re right, that page is listed as your “Posts” page, so you’ll have limited options there. Its only purpose is to display a list of your most recent posts, so you won’t get the option to add content there, or to add things below that content such as sharing buttons.

    You consequently won’t be able to add sharing buttons to that page I’m afraid.

    TZAL

    (@tzemaitis)

    OK thanks, now I know.

    It’d be good to be able to do so. Other widgets do work on the sidebar.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.