WordPress.org

Forums

List category posts
jetpack share buttons get lost using excerpt (22 posts)

  1. deraltetom
    Member
    Posted 1 year ago #

    Hi,

    first of all: great plugin!

    but I discovered one strange bug:

    using: 'catlist id=306 numberposts=1 excerpt=yes' makes my jetpack sharing buttons disappear

    using: 'catlist id=306 numberposts=1 excerpt=no' works fine.

    See examples on:
    http://rwn24.de/catlist-test1/
    http://rwn24.de/catlist-test2/

    This problem showed up using WordPress 3.6.1 and list category posts 0.33 as well as using WP3.8 and LCP 0.40.1

    Any help would be appreciated.

    http://wordpress.org/plugins/list-category-posts/

  2. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    This is pretty strange, is this Jetpack plugin something you enable per post? What happens of you add the excerpt here: http://rwn24.de/catlist-test2/ ?

    Thanks!

  3. deraltetom
    Member
    Posted 1 year ago #

    I changed 'excerpt=yes' to no in http://rwn24.de/catlist-test1/
    and 'excerpt=no' to yes in http://rwn24.de/catlist-test2/.

    Now test1 shows the Buttons and test2 does not.

    The plugin has an Option page in the backend-Settings
    (Setting: Show Buttons on Posts, pages, Events, but not on Startpage, archives, search results, Media, Event places or wysija page)
    and can be disabled in every single post by unticking a box called "Show sharing Buttons".

    "sharing" is enabled in test1 as well as in test2.

  4. danynek
    Member
    Posted 1 year ago #

    Hi there, excellent work with this plugin.
    I have same issue.

    I found that excerpt=no shows only share buttons on the bottom, but it should show this share buttons for each post on page.

    Current sample here: http://projects.mada.cz/?page_id=136 (with your plugin)

    My goal is to show it like this: http://projects.mada.cz/?page_id=147 (i used another plugin, but not so good as yours)

    Thank you

  5. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    I am really puzzled with this issue. deraltetom have you tried adding some text after the shortcode on your post?

    It's really weird, there doesn't seem to be any unclosed tags on your excerpt or anything like that. Try using content=yes to see if the same thing happens. I might have to ask

    danynek I can't see your site.

    Also, would you mind setting wp-debug to true on your site and see if there's any error report? Thank you!

  6. danynek
    Member
    Posted 1 year ago #

    my site is now enabled for not logged users.

    i added: content="yes" but with no luck, only text format has been changed.

    wp_debug log is empty.

  7. deraltetom
    Member
    Posted 1 year ago #

    Content="yes" Shows same result as excerpt="yes"
    adding text after shortcode has no effect.

    my debug.log Shows a notice. Copied it to the catlist-test2-page.
    The error is also shown on other pages.

    After loading my start-page debug.log Shows several notices and also one concerning the catlist-displayer, although the plugin is not used on that page:

    '[02-Jan-2014 20:59:01] PHP Notice: Trying to get property of non-object in /mnt/web5/a3/11/5408711/htdocs/WordPress_01/wp-content/plugins/list-category-posts/include/CatListDisplayer.php on line 177'

  8. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    I just opened a support ticket on Jetpack's forum here.

    One more thing you can try is this from their troubleshooting page:

    1. Disable all other plugins, then try connecting or using Jetpack. If Jetpack starts connecting or working properly, turn your plugins back on one-by-one until you start seeing the error again. Then note the plugin that caused this error and get in touch with us. Sometimes Jetpack and other plugins are incompatible; just let us know and we’ll see what we can do.
    2. If you are having a display issue, or the plugin step above doesn’t help, try activating Twenty Eleven or Twenty Twelve (one of the default WordPress themes) as your theme. Then try again. If your action starts working, something in your theme is likely broken and you should get in touch with your theme’s author. Be sure to let them know the troubleshooting steps that you have tried.

    Also, make sure you update to the latest version (just released) of List Category Posts.

  9. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    I don't know why the link came out wrong on the previous message, the support ticket I opened on Jetpack's forum is:
    http://wordpress.org/support/topic/issue-with-list-category-posts-plugin

  10. deraltetom
    Member
    Posted 1 year ago #

    Hi again,

    I set up a new blog for testing-purposes:

    http://medienhaus.presseagentur-funk.de/

    I only installed jetpack and list category Posts
    and chose the Twenty Eleven theme.

    The results remain the same as you can see here:
    http://medienhaus.presseagentur-funk.de/test1/
    http://medienhaus.presseagentur-funk.de/test2/

    So, let´s wait for what the jetpack developer finds out :-)

  11. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    deraltetom,
    The developers from Jetpack have created a patched version, could you please try it?

    Could you try to install this patched version of Jetpack, and let me know if this fixes your problem?
    https://github.com/Automattic/jetpack/archive/lcp.zip

    Thanks!

    Please test it and let us know if it works?
    Thank you!

  12. deraltetom
    Member
    Posted 1 year ago #

    Dear Happiness Engineers,

    installing the new Version didn´t solve the Problem, but there are changes that may lead to the solution.

    Please see

    http://medienhaus.presseagentur-funk.de/test1/

    for further Details.

  13. deraltetom
    Member
    Posted 1 year ago #

    Hi there,

    any News on this Topic?

    the jetpack-People say, they fixed a bug in their plugin (which doesn´t help yet) and that everything else would be your Job now...

  14. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    I'll check it out again, thanks!

  15. @picandocodigo have you been able to try the patch referenced on the other thread yet? http://wordpress.org/support/topic/issue-with-list-category-posts-plugin?replies=5#post-5085221

  16. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    @Ben, not yet, sorry. I'll get to this once I have some time to work on the plugin. Thanks!

  17. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    This has been fixed on version 0.46, please check if it's working as you expected.

    Thanks!

  18. deraltetom
    Member
    Posted 1 year ago #

    Sorry, no good News, Problem remains the same.

    1. using lcp with Content- or excerpt-command in Post1 makes post1´s sharing Buttons disappear

    2. using lcp with excerpt-command displays a sharing text without Buttons at the end of each excerpt. There should be no text and no Buttons at all.

    3. the title_tag command seems not to be working anymore in lcp-Version 0.46.

    4. issue that has changed/been solves: using lcp with Content-command doesn´t Show listed Posts sharing Buttons anymore.

    for examples please see
    http://medienhaus.presseagentur-funk.de/test1/
    http://medienhaus.presseagentur-funk.de/test2/

    as i am still running the rwn24.de-Blog with jetpack 2.7 and lcp 0.45

    Thanks for working on this topic

  19. fernandobt
    Member
    Plugin Author

    Posted 1 year ago #

    Did you update to version 0.46.1? That's the latest. Version 0.46 introduced the filter that the Jetpack developers mentioned for the excerpt and version 0.46.1 fixes the issue with title_tag. Please update and let me know of the results.

    Thanks!

  20. deraltetom
    Member
    Posted 1 year ago #

    title_tag got fixed in 0.46.1,
    other Problems still exist:

    1. using lcp with Content- or excerpt-command in Post1 makes post1´s jetpack sharing Buttons disappear

    2. using lcp with excerpt-command displays a sharing text without Buttons at the end of each excerpt. There should be no text and no Buttons at all.

  21. unifey
    Member
    Posted 1 year ago #

    Same thing here. I use:

    excerpt=yes excerpt_strip=yes

    The result is that the following string of texts appear after the excerpts:

    #fsb-social-bar { width: 100%; border-bottom: 1px solid #dbdbdb ...

    This did not happen before updating to v0.46

  22. deraltetom
    Member
    Posted 1 year ago #

    Hi again,

    didn´t update the plugin for a while. Now I did. The Problem is almost solved, buttons are shown now using excerpt=yes.

    But using the excerpt-command leads to another bug I mentioned earlier in the jetpack-Forum:

    If the excerpt is shorter than 55 words the plugin adds the words

    Weiterlesen » Teilen mit:Mehr

    at the end of each excerpt.

    "Weiterlesen" means read more. That seems to be a Problem with the theme - it adds a button to each excerpt on the main page. If I Change the Name of the button in the theme-settings to "read more", than "Weiterlesen" changes to "read more" too.

    "Teilen mit:" means "Sharing with:". This still is a Problem with jetpack. Jetpack allows to Input a free text in front of the Buttons. Changing the text changes the catlist-output.

    "Mehr" means "more", I haven´t figured out yet, which Setting leads to this Output.

    For examples see http://rwn24.de/schwerpunkt-energie/, http://rwn24.de/catlist-test2/ or http://medienhaus.presseagentur-funk.de/test1/

    Amazingly http://rwn24.de/catlist-test2/ doesn´t Show "Weiterlesen", allthough it should have the same Settings as http://rwn24.de/schwerpunkt-energie/. All other pages I controlled behaved like http://rwn24.de/schwerpunkt-energie/

    http://medienhaus.presseagentur-funk.de/test1/ only Shows the "Teilen mit", here: "Mitteilen via:". So the "Mehr"-Problem seems to be a theme-conflict too.

    If you can´t find the bug, it could be a solution to add a command to cut off a certain amount of characters at the end of each excerpt, like: excerpt=yes, excerpt-cutoff=12

    By the way: using "Content=yes" still hides the jetpack-Buttons.

    Cheers
    deraltetom

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • List category posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic