WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Jetpack "Share" button not working.

[Resolved] Jetpack "Share" button not working.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Contributor Tim Moore

    @tmoorewp

    This seems to work fine for me in the Chrome browser. What browser are you using?

    I’ve tried it with Firefox – the latest – and Safari.

    Funny thing is, it works on my other site and I don’t see any differences in the settings.

    Scott Jones

    @scottsjonesukcom

    I’m having this exact problem right now. Have you managed to find a solution for it yet?

    Nope.

    Can’t figure it out. I was hoping upgrading the plugin would fix it but it didn’t.

    I even tried deleting the setting and starting over. Still no cigar.

    Hope someone comes up with an answer. Seems like it should be an easy fix.

    Scott Jones

    @scottsjonesukcom

    Ah.

    I’ve just removed them all from the drop-down as a messier, temporary fix. Just allowing my patience to take over in someone smarter than me figuring this out!

    It does seem like an easy fix.

    Plugin Contributor Tim Moore

    @tmoorewp

    Are either of you using a Minify plugin, like W3 Total Cache?

    NealFox

    @nealfox

    Not me.

    I have the same issue. I click the share button and it opens the pop up window, but is just the same blog page. It’s not taking the user to the corresponding social site.

    Plugin Author Jeremy Herve

    @jeherve

    @gupster Could you post your site URL so I can have a look?

    Plugin Author Jeremy Herve

    @jeherve

    Thanks.

    Do you use any security plugin, or did you make any changes to your .htaccess file that may affect the way new windows open on your site?

    As reported here, some changes to your .htaccess file might cause issues with Javascript.

    Hi Jeremy,

    No, the .htaccess is as was when I set this up. Also the only changes have been upgrading to WP3.5 and the latest Jetpack plugin. One or the other I suspect has caused this as it was working.

    We run on Windows Server 2003.

    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?p=$1 [NC,L]

    Thanks,

    Plugin Author Jeremy Herve

    @jeherve

    Thanks for checking. Unfortunately, I do not see what could cause this issue at the moment.

    Would you mind trying to install another sharing plugin, and see if you experience similar issues with other buttons opening a pop-up on your site?

    Just installed one and it works perfectly. Sorry… 🙂

    Plugin Author Jeremy Herve

    @jeherve

    Good. We’re making progress, narrowing down the issue. Thank you! 🙂

    Could you go to Settings > Sharing in your dashboard, and change the button settings to “Official buttons”?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] Jetpack "Share" button not working.’ is closed to new replies.
Skip to toolbar