Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Jetpack Setup Infinite Redirection Loop

  • Resolved ChadCloman

    (@chadcloman)


    I’m having an issue with the Jetpack setup, where I click the “Set up Jetpack” button and it just returns to the same page with the same button, after apparently doing absolutely nothing.

    Video demonstrating the problem here: https://youtu.be/mwcDNQge42w

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support KokkieH

    (@kokkieh)

    Hi there,

    I can see icons for various browser plugins in your video, but can’t make out what they are. Do you have any ad-blocker or anti tracking browser plugins active? Those might be blocking the redirect to the WordPress.com login and/or authorization page to complete the connection.

    Also make sure you’re already logged into your WordPress.com account when you try that, and for good measure I’d recommend you clear your browser cache, and at least cookies for your site and WordPress.com, before logging into WordPress.com and your site’s admin account both before retrying.

    Let us know if none of that helps.

    Thread Starter ChadCloman

    (@chadcloman)

    Thank you for the quick response. I rebooted my PC. Cleared the browser cache. Disabled the ad blocker. Disabled the website application firewall caching. And it’s still happening.

    Then I realized I hadn’t cleared cookies. Did that. Relogged on both sites as instructed. Still having the same issue

    Uninstalled and reinstalled Jetpack. Same issue.

    I’m using a different email address for my site than for wordpress.com. Does that matter?

    Earlier today I activated jetpack on a slightly different install on the same server using this same email. Would that be a problem?

    What exactly is this setup button attempting to do? I’m not sure why wordpress.com is involved with configuring a plugin. Maybe you could explain?

    And is there any type of error logging that I could check? I know it’s the “in” thing with UI design these days to withhold as much information as possible from users, but that philosophy tends to cause problems when something goes wrong. I’m hoping you record errors somewhere. Nothing in the javascript console, unfortunately.

    Thread Starter ChadCloman

    (@chadcloman)

    Just in case it was my browser, I used the Microsoft Edge beta, which has never been to either of the domains specified here (sa.org and wordpress.com).

    Still didn’t work. So it’s probably not browser-related.

    • This reply was modified 1 year, 4 months ago by ChadCloman.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    What’s the URL of the affected site?

    Also, are you able to connect Jetpack with all other plugins deactivated?

    Thread Starter ChadCloman

    (@chadcloman)

    Thank you for responding.

    The site is http://www.sa.org/wsandbox, but you won’t be able to access it because the directory is password-protected.

    Yes, tried that too but forgot to mention it here. Disabled all plugins. Activated Jetpack. Same problem.

    • This reply was modified 1 year, 4 months ago by ChadCloman.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, that password protection could be the problem. You can only connect publicly accessible sites with Jetpack.

    If this is just a development site, try Development Mode: https://jetpack.com/support/development-mode/

    Thread Starter ChadCloman

    (@chadcloman)

    Thank you! That was the problem. I removed the directory password protection and the setup worked.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Jetpack Setup Infinite Redirection Loop’ is closed to new replies.