Support » Plugin: Jetpack by » Jetpack settings & main page not working

  • Resolved amazingant


    It’s been a little while since I updated anything in my wordpress, so I went in and updated everything — WP to 3.5, Jetpack to 2.1, and Akismet to 2.5.7, couple theme updates as well. After these updates finished, going to the Jetpack settings page, or just clicking on Jetpack from the admin area gives me the following (path modified to protect the innocent):

    Fatal error: Using $this when not in object context in /path/to/wordpress/directory/wp-content/plugins/jetpack/jetpack.php on line 688

Viewing 12 replies - 1 through 12 (of 12 total)
  • Me too – just the same – but all I did was update JetPack, so I think it is either a fault with the update or there is a wider JetPack problem.

    I plan to leave it overnight (it’s 8pm here in the UK) and check on it tomorrow.

    Error Message (also modified):
    Fatal error: Using $this when not in object context in /home/root/public_html/site_name/wp-content/plugins/jetpack/jetpack.php on line 688

    Plugin Contributor Jeremy Herve


    Thanks for the reports. It seems that the problem will happen when updating from an old version of Jetpack (pre 1.9) to 2.1.

    One work-around would be to manually upgrade to Jetpack 2.0.4, then to use the Upgrade option in your dashboard to install 2.1.

    You could also manually install the development version of Jetpack, where we have added a fix for that problem:

    Thanks, pushed the dev version you linked to onto my server and swapped the existing directory with the contents of that. No problems now. 🙂

    Plugin Contributor Christopher Finke


    Design Engineer at Automattic

    If you don’t want to install trunk (since changes may be made between now and when you download it), you can use this link: which is 2.1 plus a fix for the upgrade bug and nothing more.



    Thought I’d let you know that I only updated from the previous version (2.0.4) and I also had an error when trying to view the settings page. It also caused some weird conflict with some other plugins on the particular site I was testing at the time.

    I downloaded and installed version 2.1.1a1 from your above link, and it’s fixed it.

    However I now need to go and manually upload this version to around another 20+ websites.. then go through the settings page several times to disable the new features you’ve added. This is always annoying, and whilst I hope you’ll eventually address this (leave all disabled as default)…

    It would be great if you could just release your ‘fixed’ version on right away so we can all just update as normal. The current version is clearly broken.


    Thank you. Uploading 2.1.1a1’s files worked.

    Will 2.1.1a1 be released publicly soon?

    Fortunately, it seems that this bug is only present on one site (also an upgrade “missing” 2.0.4).

    Plugin Contributor Christopher Finke


    Design Engineer at Automattic

    2.1.1 was released a few minutes ago. Sorry for the inconvenience.

    Thank you Christopher and Jeremy.

    I want to say publicly thank you for how good the WordPress team is. Recently “upgrades” by Apple and Google have each caused me significant workflow setbacks. The Apple forum has seen no response from the company or developers to several pages of complaints over several weeks. Google do not even entertain responses. You responded within a couple of hours and offered a complete fix. Perfect.

    Also – what triggered this update for me was the failure of the PollDaddy plugin to work when installed and activated. I found a passing reference to incompatibility with an older release of Jetpack, hence I updated to 2.1. It still failed. Now I have implemented 2.1.1 and re-activated PollDaddy, it worked first time. I am recording this in case anyone else has the Polldaddy problem – upgrade to Jetpack 2.1.1.

    Hello I just upgraded to 2.1.1.
    But then my main page slider images and portfolio images disappeared.
    When page loads the images are shown for a second and then disappear.
    Just the loading image is rolling and rolling again.
    Unfortunately, I had to deactivate the plugin.

    Plugin Contributor Jeremy Herve


    @wp_amateur Could you start a new thread, since your issue seems to be different?

    If you could post your site URL there, we can have a look at your site for you.

    You may also want to disable your other plugins, one by one, to see if one of them conflicts with Jetpack.


    Sorry about that. I read the title “main page not working” and jumped in.

    I disabled all other plugins but none of them seems to conflict.

    I opened a new thread on

    Thank you!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Jetpack settings & main page not working’ is closed to new replies.